summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit07272daa2c6654b0af606c5eba07f275dfacefc7 (patch)
treea0bf9e60a8bdf3b39e102939dd41fb3253bed518
downloadaur-07272daa2c6654b0af606c5eba07f275dfacefc7.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
-rw-r--r--fraqtive.install11
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6f60f41eb9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = fraqtive
+ pkgdesc = Program for drawing Mandelbrot and Julia fractals
+ pkgver = 0.4.6
+ pkgrel = 1
+ url = http://fraqtive.mimec.org/
+ install = fraqtive.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = hicolor-icon-theme
+ depends = qt4
+ depends = glu
+ depends = xdg-utils
+ source = http://downloads.sourceforge.net/fraqtive/fraqtive-0.4.6.tar.bz2
+ sha256sums = 5b799a1da39de1e6aa28674e3c2a2359df630c42f9d9b3fa051dee0db4aace4c
+
+pkgname = fraqtive
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97e059156c41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=fraqtive
+pkgver=0.4.6
+pkgrel=1
+pkgdesc="Program for drawing Mandelbrot and Julia fractals"
+arch=('i686' 'x86_64')
+url="http://fraqtive.mimec.org/"
+license=('GPL')
+depends=('hicolor-icon-theme' 'qt4' 'glu' 'xdg-utils')
+install=$pkgname.install
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2)
+sha256sums=('5b799a1da39de1e6aa28674e3c2a2359df630c42f9d9b3fa051dee0db4aace4c')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+ ./configure -prefix ${pkgdir}/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+ make DESTDIR=${pkgdir} install
+}
diff --git a/fraqtive.install b/fraqtive.install
new file mode 100644
index 000000000000..b711352cb167
--- /dev/null
+++ b/fraqtive.install
@@ -0,0 +1,11 @@
+post_install() {
+ which xdg-icon-resource 1>/dev/null 2>/dev/null && xdg-icon-resource forceupdate || true
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}