summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-10-29 21:53:37 +0300
committerCaleb Maclennan2020-10-29 21:53:37 +0300
commitfe7f30df5f3f55926519f0ba1b4d7358d2f5aeb5 (patch)
tree40c872da37c5183f19eae9c33da29f5a2b64c4eb
parent9df34ce24c3d537a384098d630fd5548c31ae81f (diff)
downloadaur-fraunces-font.tar.gz
upgpkg: fraunces-font 1.000-1
upstream release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 22 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e86169ac53a4..73baaa7bf9bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,18 @@
pkgbase = fraunces-font
pkgdesc = A display, “Old Style” soft-serif typeface inspired by early 20th century typefaces
- pkgver = 0.001
+ pkgver = 1.000
pkgrel = 1
url = https://github.com/undercasetype/Fraunces
arch = any
license = OFL
- source = https://github.com/undercasetype/Fraunces/archive/611c698e29de78d133beac7534a0ac7b914682cb/ttf-fraunces-variable-0.001.zip
- sha256sums = 44b6f52536b8fdabae2e938344befbe2bacbc7800909c086401f4a28197fad7e
+ source = https://github.com/undercasetype/Fraunces/releases/download/1.000/UnderCaseType_Fraunces_1.000.zip
+ sha256sums = 8d8b81dfaeb89433f5c908e1d8d0a4b202bd627bd80d4cd5ff56f311fdcad19f
+
+pkgname = ttf-fraunces
+ provides = fraunces-font
+
+pkgname = otf-fraunces
+ provides = fraunces-font
pkgname = ttf-fraunces-variable
pkgdesc = A display, “Old Style” soft-serif typeface inspired by early 20th century typefaces (variable)
diff --git a/PKGBUILD b/PKGBUILD
index db281fbe068b..81a9ecc9644b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,31 @@
_project=fraunces
pkgbase=${_project}-font
-pkgname=("ttf-$_project-variable") # "ttf-$_project" "otf-$_project"
-pkgver=0.001
-_sha=611c698e29de78d133beac7534a0ac7b914682cb
+pkgname=("ttf-$_project" "otf-$_project" "ttf-$_project-variable")
+pkgver=1.000
pkgrel=1
pkgdesc='A display, “Old Style” soft-serif typeface inspired by early 20th century typefaces'
arch=('any')
url="https://github.com/undercasetype/${_project^}"
license=('OFL')
-source=("$url/archive/$_sha/$pkgname-$pkgver.zip")
-sha256sums=('44b6f52536b8fdabae2e938344befbe2bacbc7800909c086401f4a28197fad7e')
+_foundry=UnderCaseType_
+source=("$url/releases/download/$pkgver/$_foundry${_project^}_$pkgver.zip")
+sha256sums=('8d8b81dfaeb89433f5c908e1d8d0a4b202bd627bd80d4cd5ff56f311fdcad19f')
package_otf-fraunces () {
- :
+ provides=("$pkgbase")
+ cd "$_foundry${_project^}_$pkgver/Fonts - Desktop/static/otf"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/OTF/" *.otf
}
package_ttf-fraunces () {
- :
+ provides=("$pkgbase")
+ cd "$_foundry${_project^}_$pkgver/Fonts - Desktop/static/ttf"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" *.ttf
}
package_ttf-fraunces-variable () {
pkgdesc+=" (variable)"
- cd "${_project^}-$_sha"
- install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" fonts/*\[*\].ttf
- install -Dm644 OFL.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+ cd "$_foundry${_project^}_$pkgver/Fonts - Desktop/"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" *.ttf
}