summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorModelmat2020-01-06 14:14:31 +1100
committerModelmat2020-01-06 14:14:31 +1100
commite8c093410074d7767a9053f9faf826dd63d1b282 (patch)
tree429d8d4a94ef8acf8967d995b41fe1919d57c493
downloadaur-e8c093410074d7767a9053f9faf826dd63d1b282.tar.gz
Adds frc-characterization
-rw-r--r--.SRCINFO21
-rwxr-xr-x.gitignore6
-rwxr-xr-xPKGBUILD36
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72917b5126a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = frc-characterization-git
+ pkgdesc = Tools to help FRC teams measure the physical parameters of their robot
+ pkgver = 2020.229
+ pkgrel = 1
+ url = https://github.com/wpilibsuite/frc-characterization
+ arch = x86_64
+ license = Apache
+ depends = python-matplotlib
+ depends = python-statsmodels
+ depends = python-frccontrol-git
+ depends = python-pynetworktables
+ depends = python-argcomplete
+ depends = python-mako
+ depends = python-console-menu-git
+ depends = tk
+ provides = frc-characterization
+ source = frc-characterization-git::git://github.com/wpilibsuite/frc-characterization
+ md5sums = SKIP
+
+pkgname = frc-characterization-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100755
index 000000000000..2bb710d1b669
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src
+pkg
+*.tar.xz
+*.tar.gz
+*.tar
+frc-characterization-git/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..cbb859e89483
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Modelmat <modelmat@outlook.com.au>
+
+pkgname=frc-characterization-git
+pkgver=2020.229
+pkgrel=1
+pkgdesc="Tools to help FRC teams measure the physical parameters of their robot"
+arch=("x86_64")
+url="https://github.com/wpilibsuite/frc-characterization"
+license=("Apache")
+provides=("frc-characterization")
+depends=("python-matplotlib"
+ "python-statsmodels"
+ "python-frccontrol-git"
+ "python-pynetworktables"
+ "python-argcomplete"
+ "python-mako"
+ "python-console-menu-git"
+ "tk")
+source=("$pkgname"::"git://github.com/wpilibsuite/frc-characterization")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ year=$(date +%Y)
+ echo $year.$(git rev-list --count --after="master@{$(($year - 1))-01-01}" master)
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+}