summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Bruckner2017-07-29 21:20:24 +0200
committerMax Bruckner2017-07-29 21:20:24 +0200
commit7d1a4a243947579b7175af1f0ad5e76e061e6f01 (patch)
treecd752ce8e54b00bec26cc6819c79252ccafd0836
parent96c60463c81222e6594ab4b28ff352754c591c63 (diff)
downloadaur-7d1a4a243947579b7175af1f0ad5e76e061e6f01.tar.gz
freac-cvs_20170729-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
-rw-r--r--help-path.patch19
3 files changed, 12 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e654171aab6..b0bc78964045 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
# Generated by mksrcinfo v8
-# Wed Jun 28 16:48:58 UTC 2017
+# Sat Jul 29 19:20:07 UTC 2017
pkgbase = freac
pkgdesc = Audio converter and CD ripper with support for various popular formats and encoders.
- pkgver = cvs_20170317
- pkgrel = 3
+ pkgver = cvs_20170729
+ pkgrel = 1
url = http://www.freac.org/
arch = i686
arch = x86_64
license = GPL2
- depends = freac_cdk
+ depends = freac_cdk>=cvs_20170729
depends = mpg123
depends = libvorbis
depends = libsndfile
@@ -21,12 +21,10 @@ pkgbase = freac
depends = speex
depends = libsamplerate
depends = libmp4v2
- source = http://sourceforge.net/projects/bonkenc/files/snapshots/20170317/freac-20170317.tar.gz
+ source = http://sourceforge.net/projects/bonkenc/files/snapshots/20170729/freac-20170729.tar.gz
source = freac.desktop
- source = help-path.patch
- sha512sums = a416faf220459c5eba6718816991ace861d5895a63e1cf5e7968834248122f563c47b20361b26e604f1e02752ccfd5cec58cc16e47258ecdb505d015da4e3555
+ sha512sums = 8c1fa8f7868d6bf09f87ed619cfef1aec6f01ee1d932bf965249f27ba5eb3d3a07b3b861ef9b41003be89fc531f4603c836a1e98267530ba9600bc1f85d06966
sha512sums = 61634e759c4621dee3485ef82c584faa6d8e4b67d5240a5b929b4b166913e6ea031d03a7fd85422d4422841700d6ab140b3815e12777c53c9254ebffeb8ae021
- sha512sums = b468313324929288f57af311767e85d603f04a09223bdb105584dab52dced2bd21468e6dca34e1e89e3c925609a4a71ff0b5c489317645bc04c571d962ca8588
pkgname = freac
diff --git a/PKGBUILD b/PKGBUILD
index 217e3e7d14d0..6f8cccb343ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,22 @@
# Original author: archtux <antonio dot arias99999 at gmail dot com>
pkgname=freac
-_realpkgver=20170317
+_realpkgver=20170729
pkgver=cvs_${_realpkgver}
-pkgrel=3
+pkgrel=1
pkgdesc="Audio converter and CD ripper with support for various popular formats and encoders."
arch=('i686' 'x86_64')
url="http://www.freac.org/"
license=('GPL2')
-depends=('freac_cdk' 'mpg123' 'libvorbis' 'libsndfile' 'flac' 'lame' 'libfdk-aac' 'faac' 'faad2' 'opus' 'speex' 'libsamplerate' 'libmp4v2')
+depends=("freac_cdk>=$pkgver" 'mpg123' 'libvorbis' 'libsndfile' 'flac' 'lame' 'libfdk-aac' 'faac' 'faad2' 'opus' 'speex' 'libsamplerate' 'libmp4v2')
-source=( "http://sourceforge.net/projects/bonkenc/files/snapshots/${_realpkgver}/freac-${_realpkgver}.tar.gz" freac.desktop help-path.patch)
-sha512sums=('a416faf220459c5eba6718816991ace861d5895a63e1cf5e7968834248122f563c47b20361b26e604f1e02752ccfd5cec58cc16e47258ecdb505d015da4e3555'
- '61634e759c4621dee3485ef82c584faa6d8e4b67d5240a5b929b4b166913e6ea031d03a7fd85422d4422841700d6ab140b3815e12777c53c9254ebffeb8ae021'
- 'b468313324929288f57af311767e85d603f04a09223bdb105584dab52dced2bd21468e6dca34e1e89e3c925609a4a71ff0b5c489317645bc04c571d962ca8588')
+source=( "http://sourceforge.net/projects/bonkenc/files/snapshots/${_realpkgver}/freac-${_realpkgver}.tar.gz" freac.desktop)
+sha512sums=('8c1fa8f7868d6bf09f87ed619cfef1aec6f01ee1d932bf965249f27ba5eb3d3a07b3b861ef9b41003be89fc531f4603c836a1e98267530ba9600bc1f85d06966'
+'61634e759c4621dee3485ef82c584faa6d8e4b67d5240a5b929b4b166913e6ea031d03a7fd85422d4422841700d6ab140b3815e12777c53c9254ebffeb8ae021')
prepare() {
cd "${pkgname/_/-}-${_realpkgver}" || exit 1
find . -type f -exec sed -i 's!/usr/local!/usr!g' {} \;
- patch -p1 -i"$srcdir/help-path.patch" src/startgui.cpp
}
build() {
diff --git a/help-path.patch b/help-path.patch
deleted file mode 100644
index bfffb25f634c..000000000000
--- a/help-path.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-*** startgui.cpp 2017-03-03 14:14:36.000000000 +0100
---- fixed-startgui.cpp 2017-06-28 18:44:58.171398441 +0200
-***************
-*** 1387,1393 ****
-
- i18n->SetContext("Menu::Help");
-
-! S::System::System::OpenURL(String("file://").Append(GUI::Application::GetApplicationDirectory()).Append(Config::Get()->documentationPath).Append("manual/").Append(i18n->TranslateString("index_en.html")));
- }
-
- Void freac::freacGUI::ShowTipOfTheDay()
---- 1387,1393 ----
-
- i18n->SetContext("Menu::Help");
-
-! S::System::System::OpenURL(String("file://").Append(Config::Get()->documentationPath).Append("manual/").Append(i18n->TranslateString("index_en.html")));
- }
-
- Void freac::freacGUI::ShowTipOfTheDay()