summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Bruckner2017-06-28 18:49:44 +0200
committerMax Bruckner2017-06-28 18:49:44 +0200
commit96c60463c81222e6594ab4b28ff352754c591c63 (patch)
treeb026a48698d38c87ce5e9f1e243f791a7b086f6c
parentf7d265c437af022ec46bcb137119ef3efa3e92d4 (diff)
downloadaur-96c60463c81222e6594ab4b28ff352754c591c63.tar.gz
freac-cvs_20170317-3: Fix documentation path
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--help-path.patch19
3 files changed, 28 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca4b6445ace6..1e654171aab6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Mar 24 01:51:14 UTC 2017
+# Wed Jun 28 16:48:58 UTC 2017
pkgbase = freac
pkgdesc = Audio converter and CD ripper with support for various popular formats and encoders.
pkgver = cvs_20170317
- pkgrel = 2
+ pkgrel = 3
url = http://www.freac.org/
arch = i686
arch = x86_64
@@ -23,8 +23,10 @@ pkgbase = freac
depends = libmp4v2
source = http://sourceforge.net/projects/bonkenc/files/snapshots/20170317/freac-20170317.tar.gz
source = freac.desktop
+ source = help-path.patch
sha512sums = a416faf220459c5eba6718816991ace861d5895a63e1cf5e7968834248122f563c47b20361b26e604f1e02752ccfd5cec58cc16e47258ecdb505d015da4e3555
sha512sums = 61634e759c4621dee3485ef82c584faa6d8e4b67d5240a5b929b4b166913e6ea031d03a7fd85422d4422841700d6ab140b3815e12777c53c9254ebffeb8ae021
+ sha512sums = b468313324929288f57af311767e85d603f04a09223bdb105584dab52dced2bd21468e6dca34e1e89e3c925609a4a71ff0b5c489317645bc04c571d962ca8588
pkgname = freac
diff --git a/PKGBUILD b/PKGBUILD
index c52abebd22ff..217e3e7d14d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,22 @@
pkgname=freac
_realpkgver=20170317
pkgver=cvs_${_realpkgver}
-pkgrel=2
+pkgrel=3
pkgdesc="Audio converter and CD ripper with support for various popular formats and encoders."
arch=('i686' 'x86_64')
url="http://www.freac.org/"
license=('GPL2')
depends=('freac_cdk' 'mpg123' 'libvorbis' 'libsndfile' 'flac' 'lame' 'libfdk-aac' 'faac' 'faad2' 'opus' 'speex' 'libsamplerate' 'libmp4v2')
-source=( "http://sourceforge.net/projects/bonkenc/files/snapshots/${_realpkgver}/freac-${_realpkgver}.tar.gz" freac.desktop)
+source=( "http://sourceforge.net/projects/bonkenc/files/snapshots/${_realpkgver}/freac-${_realpkgver}.tar.gz" freac.desktop help-path.patch)
sha512sums=('a416faf220459c5eba6718816991ace861d5895a63e1cf5e7968834248122f563c47b20361b26e604f1e02752ccfd5cec58cc16e47258ecdb505d015da4e3555'
- '61634e759c4621dee3485ef82c584faa6d8e4b67d5240a5b929b4b166913e6ea031d03a7fd85422d4422841700d6ab140b3815e12777c53c9254ebffeb8ae021')
+ '61634e759c4621dee3485ef82c584faa6d8e4b67d5240a5b929b4b166913e6ea031d03a7fd85422d4422841700d6ab140b3815e12777c53c9254ebffeb8ae021'
+ 'b468313324929288f57af311767e85d603f04a09223bdb105584dab52dced2bd21468e6dca34e1e89e3c925609a4a71ff0b5c489317645bc04c571d962ca8588')
prepare() {
cd "${pkgname/_/-}-${_realpkgver}" || exit 1
find . -type f -exec sed -i 's!/usr/local!/usr!g' {} \;
+ patch -p1 -i"$srcdir/help-path.patch" src/startgui.cpp
}
build() {
diff --git a/help-path.patch b/help-path.patch
new file mode 100644
index 000000000000..bfffb25f634c
--- /dev/null
+++ b/help-path.patch
@@ -0,0 +1,19 @@
+*** startgui.cpp 2017-03-03 14:14:36.000000000 +0100
+--- fixed-startgui.cpp 2017-06-28 18:44:58.171398441 +0200
+***************
+*** 1387,1393 ****
+
+ i18n->SetContext("Menu::Help");
+
+! S::System::System::OpenURL(String("file://").Append(GUI::Application::GetApplicationDirectory()).Append(Config::Get()->documentationPath).Append("manual/").Append(i18n->TranslateString("index_en.html")));
+ }
+
+ Void freac::freacGUI::ShowTipOfTheDay()
+--- 1387,1393 ----
+
+ i18n->SetContext("Menu::Help");
+
+! S::System::System::OpenURL(String("file://").Append(Config::Get()->documentationPath).Append("manual/").Append(i18n->TranslateString("index_en.html")));
+ }
+
+ Void freac::freacGUI::ShowTipOfTheDay()