summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyson Christoforo2021-01-16 13:17:40 +0000
committerGreyson Christoforo2021-01-16 13:17:40 +0000
commit3941742535d37b8e6dc1e48a75526ebe6c4c9473 (patch)
tree60a7fe6319da2dd9f22b12e6cc3fbe3c1d1ace77
parenteb2067a6302fb61873069bc3c117cfa9233d1b46 (diff)
downloadaur-3941742535d37b8e6dc1e48a75526ebe6c4c9473.tar.gz
change install invocation
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 762e58f25166..edac71b4cda4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -61,6 +61,7 @@ pkgver() {
prepare() {
cd FreeCAD
+ #git checkout 927fdc9edc
}
build() {
@@ -70,29 +71,32 @@ build() {
-D BUILD_ENABLE_CXX_STD=C++14 \
-D BUILD_QT5=ON \
-D CMAKE_INSTALL_PREFIX="" \
- -D CMAKE_BUILD_TYPE=Release \
+ -D CMAKE_BUILD_TYPE=None \
-D CMAKE_C_FLAGS="${CFLAGS} -fPIC -w" \
-D CMAKE_CXX_FLAGS="${CXXFLAGS} -fPIC -w" \
-D FREECAD_USE_EXTERNAL_PIVY=ON \
-D FREECAD_USE_OCC_VARIANT="Official Version" \
-D FREECAD_USE_QT_FILEDIALOG=ON \
-D PYTHON_EXECUTABLE=/usr/bin/python \
- -G Ninja -B "${srcdir}/build" -S .
+ -G Ninja \
+ -B build_dir \
+ -S .
- ninja -C "${srcdir}/build"
+ cmake --build build_dir
}
check() {
- DESTDIR="${srcdir}/check" ninja -C "${srcdir}/build" install
+ cd FreeCAD
+ DESTDIR=check cmake --build build_dir -- install
- cd "${srcdir}/check"
+ cd build_dir/check
LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:lib bin/FreeCADCmd --console --run-test 0
}
package() {
cd FreeCAD
local _destdir=/usr/local/freecad # maybe this belongs in /opt/freecad-git
- DESTDIR="${pkgdir}${_destdir}" ninja -C "${srcdir}/build" install
+ DESTDIR="${pkgdir}${_destdir}" cmake --build build_dir -- install
mkdir -p "${pkgdir}"/usr/{share,bin,lib}