summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Piédallu2018-09-21 18:28:58 +0200
committerFélix Piédallu2018-09-21 18:28:58 +0200
commit74a2928cdbdd9b89ab32adb454edd222029fde83 (patch)
tree8162ecca0542b44d6140c0e279313fdd9d925500
parenta40d92e4760d028b12f5d416ec1d8ebdf45332e5 (diff)
downloadaur-74a2928cdbdd9b89ab32adb454edd222029fde83.tar.gz
Add temporary patch for git bugs
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD7
-rw-r--r--temporary_fixes.patch26
4 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 712a37639d33..781623a45638 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -35,7 +35,9 @@ pkgbase = freecad-linkstage3-git
depends = python2-shiboken2
conflicts = freecad
source = git+https://github.com/realthunder/FreeCAD.git#branch=LinkStage3
+ source = temporary_fixes.patch
sha256sums = SKIP
+ sha256sums = e6f374849dd96ac198c92ca33082ede99d35d516a1986b09fdbaaa9b4d663e2a
pkgname = freecad-linkstage3-git
diff --git a/.gitignore b/.gitignore
index f71c635dafda..61c4a9ba0c4d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!temporary_fixes.patch
diff --git a/PKGBUILD b/PKGBUILD
index d8bafab96edc..0ed366a33679 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -67,9 +67,11 @@ optdepends=(
_gitname='FreeCAD'
source=(
"git+https://github.com/realthunder/FreeCAD.git#branch=LinkStage3"
+ 'temporary_fixes.patch'
)
sha256sums=(
'SKIP'
+ 'e6f374849dd96ac198c92ca33082ede99d35d516a1986b09fdbaaa9b4d663e2a'
)
@@ -78,6 +80,11 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/_//'
}
+prepare() {
+ cd "${srcdir}/${_gitname}"
+ patch -Np1 -i "${srcdir}/temporary_fixes.patch"
+}
+
build() {
cd "${srcdir}/${_gitname}"
diff --git a/temporary_fixes.patch b/temporary_fixes.patch
new file mode 100644
index 000000000000..20ce71f76bea
--- /dev/null
+++ b/temporary_fixes.patch
@@ -0,0 +1,26 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 439c581f4..87c6308be 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -734,7 +734,7 @@ endif()
+ add_compile_options(${OPENMPI_CFLAGS})
+ link_directories(${OPENMPI_LIBRARY_DIRS})
+ link_libraries(${OPENMPI_LIBRARIES})
+- find_file(MpidotH mpi.h PATHS ${OPENMPI_INCLUDE_DIRS} NO_DEFAULT_PATH)
++ find_file(MpidotH mpi.h PATHS ${OPENMPI_INCLUDE_DIRS})
+ if(NOT MpidotH)
+ message( WARNING "mpi.h was not found. Check for error above.")
+ endif()
+diff --git a/src/Gui/View3DInventorViewer.cpp b/src/Gui/View3DInventorViewer.cpp
+index 515857fe7..02ad4d891 100644
+--- a/src/Gui/View3DInventorViewer.cpp
++++ b/src/Gui/View3DInventorViewer.cpp
+@@ -2822,7 +2822,7 @@ void View3DInventorViewer::viewSelection()
+ default:
+ break;
+ }
+- cam->viewBoundingBox(box,aspectratio,1.0);
++ // cam->viewBoundingBox(box,aspectratio,1.0);
+ }
+
+ root->unref();