summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVadim Yanitskiy2023-12-22 14:39:05 +0700
committerVadim Yanitskiy2023-12-22 14:40:23 +0700
commit80e93e1f85f227369ada820f5b3b99a9f2c0fea5 (patch)
tree5e549dbfab19330cbbfaa03202aed977a9ee3408
downloadaur-80e93e1f85f227369ada820f5b3b99a9f2c0fea5.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f80513b4cea8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = freecalypso-ffs-editor-bin
+ pkgdesc = FreeCalypso FFS (Flash File System) editor firmware images
+ pkgver = r2
+ pkgrel = 1
+ url = https://www.freecalypso.org/hg/ffs-editor
+ arch = any
+ groups = freecalypso
+ license = custom
+ conflicts = freecalypso-ffs-editor-bin-hg
+ source = https://www.freecalypso.org/pub/GSM/FreeCalypso/ffs-editor-r2.tar.bz2
+ sha256sums = 6384f6aed462bac1f035b313a3e43382af06e0217a19b759e07dbcd5a570c5d2
+
+pkgname = freecalypso-ffs-editor-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6677b6fd8457
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Vadim Yanitskiy <fixeria@osmocom.org>
+
+_pkgname=ffs-editor
+pkgname=freecalypso-ffs-editor-bin
+pkgver=r2
+pkgrel=1
+pkgdesc="FreeCalypso FFS (Flash File System) editor firmware images"
+arch=('any')
+url="https://www.freecalypso.org/hg/${_pkgname}"
+license=('custom')
+groups=('freecalypso')
+conflicts=("${pkgname}-hg")
+_tarname=${_pkgname}-${pkgver}
+source=("https://www.freecalypso.org/pub/GSM/FreeCalypso/${_tarname}.tar.bz2")
+sha256sums=('6384f6aed462bac1f035b313a3e43382af06e0217a19b759e07dbcd5a570c5d2')
+
+package() {
+ cd "${_tarname}"
+
+ # XXX: no docs, no LICENSE file
+
+ # DESTDIR is not respected, use INSTALL_PREFIX instead
+ make INSTALL_PREFIX="${pkgdir}/opt/freecalypso/" install
+}