summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVadim Yanitskiy2023-09-01 02:04:14 +0700
committerVadim Yanitskiy2023-09-01 02:04:14 +0700
commit9041f0e0591e82d2ad6f8ae5c4d2b50127fb97ed (patch)
tree405d231c2dd4fe866c38e7f8f7dd8ce472dbf270
downloadaur-9041f0e0591e82d2ad6f8ae5c4d2b50127fb97ed.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD40
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37953be33b4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = freecalypso-sim-tools-hg
+ pkgdesc = FreeCalypso SIM card tools
+ pkgver = r103.3477438b5706
+ pkgrel = 1
+ url = https://www.freecalypso.org/hg/fc-sim-tools
+ arch = x86_64
+ arch = i686
+ groups = freecalypso
+ license = custom
+ makedepends = mercurial
+ source = hg+https://www.freecalypso.org/hg/fc-sim-tools
+ md5sums = SKIP
+
+pkgname = freecalypso-sim-tools-hg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..404fa631f11a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Vadim Yanitskiy <fixeria@osmocom.org>
+
+_hgname=fc-sim-tools
+_pkgname=freecalypso-sim-tools
+pkgname="${_pkgname}-hg"
+pkgver=r103.3477438b5706
+pkgrel=1
+pkgdesc="FreeCalypso SIM card tools"
+arch=('x86_64' 'i686')
+url="https://www.freecalypso.org/hg/${_hgname}"
+license=('custom')
+groups=('freecalypso')
+depends=()
+makedepends=('mercurial')
+source=("hg+https://www.freecalypso.org/hg/${_hgname}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_hgname}"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+build() {
+ cd "${_hgname}"
+ make
+}
+
+package() {
+ cd "${_hgname}"
+
+ install -d "${pkgdir}/opt"
+ install -d "${pkgdir}/usr/share/doc/${_pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+
+ # DESTDIR is not respected, '/opt/freecalypso' is hard-coded.
+ # The project's author is strongly against using any other directory.
+ make install
+ cp -r /opt/freecalypso "${pkgdir}/opt/"
+ cp -r doc/* "${pkgdir}/usr/share/doc/${_pkgname}/"
+}