summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVadim Yanitskiy2023-09-01 15:33:52 +0700
committerVadim Yanitskiy2023-09-01 15:44:13 +0700
commitd417f6d4a43e1d2f34a7c0b60b88cd8b2f650d04 (patch)
treefb443a9e637646f70521c6e3e8abdaa53cb93d80
parent0f13ded2b6dc1d29659c506dbd56f2b20aff3f38 (diff)
downloadaur-d417f6d4a43e1d2f34a7c0b60b88cd8b2f650d04.tar.gz
New (release) package: freecalypso-tools r19
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
-rw-r--r--ringtools_imy_fix_tdma_durations.diff33
3 files changed, 59 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 741759361efc..2be88a8aed0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
-pkgbase = freecalypso-tools-hg
+pkgbase = freecalypso-tools
pkgdesc = FreeCalypso host tools package
- pkgver = r964.a96cb97b66a2
+ pkgver = r19
pkgrel = 1
url = https://www.freecalypso.org/hg/freecalypso-tools
arch = x86_64
arch = i686
groups = freecalypso
license = custom
- makedepends = mercurial
- source = hg+https://www.freecalypso.org/hg/freecalypso-tools
- md5sums = SKIP
+ conflicts = freecalypso-tools-hg
+ source = https://www.freecalypso.org/pub/GSM/FreeCalypso/fc-host-tools-r19.tar.bz2
+ source = ringtools_imy_fix_tdma_durations.diff
+ sha256sums = a095b309498f30a0bf018692792c84800c2f025ac583afc63a42945186e694fe
+ sha256sums = 312e2b2c0720c076d3f0a43c12d29013645609303fa079da269c2784f743ea90
-pkgname = freecalypso-tools-hg
+pkgname = freecalypso-tools
diff --git a/PKGBUILD b/PKGBUILD
index e4ce999fb5f2..282ff318369c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,37 @@
# Maintainer: Vadim Yanitskiy <fixeria@osmocom.org>
-_pkgname=freecalypso-tools
-pkgname="${_pkgname}-hg"
-pkgver=r964.a96cb97b66a2
+pkgname=freecalypso-tools
+pkgver=r19
pkgrel=1
pkgdesc="FreeCalypso host tools package"
arch=('x86_64' 'i686')
-url="https://www.freecalypso.org/hg/${_pkgname}"
+url="https://www.freecalypso.org/hg/${pkgname}"
license=('custom')
groups=('freecalypso')
-depends=()
-makedepends=('mercurial')
-source=("hg+https://www.freecalypso.org/hg/${_pkgname}")
-md5sums=('SKIP')
+conflicts=("${pkgname}-hg")
+_tarname=fc-host-tools-${pkgver}
+source=("https://www.freecalypso.org/pub/GSM/FreeCalypso/${_tarname}.tar.bz2"
+ 'ringtools_imy_fix_tdma_durations.diff')
+sha256sums=('a095b309498f30a0bf018692792c84800c2f025ac583afc63a42945186e694fe'
+ '312e2b2c0720c076d3f0a43c12d29013645609303fa079da269c2784f743ea90')
-pkgver() {
- cd "${_pkgname}"
- printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+prepare() {
+ cd "${_tarname}"
+ # https://www.freecalypso.org/hg/freecalypso-tools/rev/a96cb97b66a2
+ patch -p1 < "${srcdir}/ringtools_imy_fix_tdma_durations.diff"
}
build() {
- cd "${_pkgname}"
+ cd "${_tarname}"
make
}
package() {
- cd "${_pkgname}"
+ cd "${_tarname}"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
- install -d "${pkgdir}/usr/share/doc/${_pkgname}"
- cp -r doc/* "${pkgdir}/usr/share/doc/${_pkgname}/"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -d "${pkgdir}/usr/share/doc/${pkgname}"
+ cp -r doc/* "${pkgdir}/usr/share/doc/${pkgname}/"
# DESTDIR is not respected, use INSTALL_PREFIX instead
make INSTALL_PREFIX="${pkgdir}/opt/freecalypso/" install
diff --git a/ringtools_imy_fix_tdma_durations.diff b/ringtools_imy_fix_tdma_durations.diff
new file mode 100644
index 000000000000..62049de835dd
--- /dev/null
+++ b/ringtools_imy_fix_tdma_durations.diff
@@ -0,0 +1,33 @@
+# HG changeset patch
+# User Mychaela Falconia <falcon@freecalypso.org>
+# Date 1693510698 0
+# Thu Aug 31 19:38:18 2023 +0000
+# Node ID a96cb97b66a221425071357950bfeb616c1ec9c7
+# Parent b515a97e5dff252b24c41fecc139f8db19f6a637
+ringtools/imy: fix duplicate definition of tdma_durations[]
+
+The bug was reported by Vadim Yanitskiy <fixeria@osmocom.org>,
+although the present fix is slightly different from the contributed
+patch: because main.c doesn't need this tdma_durations[] array
+at all, let's simply remove the reference to this array from main.c
+rather than turn it into an extern.
+
+I no longer remember my original thought flow that resulted (by mistake)
+in tdma_durations[] being multiply defined in main.c and durations.c.
+My intent might have been to define all globals in main.c and have
+the reference in durations.c be an extern - and I missed that extern -
+but without clear memory, I have no certainty. In any case, having
+this data array defined in the same module that fills it (durations.c)
+is sensible, so let's make it the new way.
+
+diff -r b515a97e5dff -r a96cb97b66a2 ringtools/imy/main.c
+--- a/ringtools/imy/main.c Mon Aug 28 03:52:53 2023 +0000
++++ b/ringtools/imy/main.c Thu Aug 31 19:38:18 2023 +0000
+@@ -9,7 +9,6 @@
+ char *imy_filename;
+ char melody_str_buf[MELODY_BUF_SIZE];
+ unsigned beats_per_min = 120;
+-unsigned tdma_durations[6][4];
+ FILE *outF;
+
+ main(argc, argv)