summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2021-05-15 23:49:15 +0200
committerFrederic Bezies2021-05-15 23:49:15 +0200
commit70a75ead41a4bbf3408bf48181bf70bbf60c6cc0 (patch)
treeee52d04a9067d821405d49c1e21022400507b9c8
parent78685ec05a7f7df4b401712b2078f5319c09accb (diff)
downloadaur-70a75ead41a4bbf3408bf48181bf70bbf60c6cc0.tar.gz
PKGBUILD cleanup
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--freeciv.install11
3 files changed, 9 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9332827dbb33..b48301291d26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,15 +3,17 @@ pkgbase = freeciv-sdl2
pkgver = 2.6.4
pkgrel = 1
url = http://freeciv.org
- install = freeciv.install
arch = i686
arch = x86_64
license = GPL
- depends = hicolor-icon-theme
depends = sdl2_image
depends = sdl2_mixer
depends = sdl2_gfx
depends = sdl2_ttf
+ depends = lua53
+ depends = gtk3
+ depends = qt5-base
+ depends = imagemagick
conflicts = freeciv
options = !libtool
source = http://files.freeciv.org/stable/freeciv-2.6.4.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
index a5b37f7aac67..fcc2e4d7000e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,22 +12,24 @@ pkgdesc="A multiuser clone of the famous Microprose game of Civilization - SDL2
arch=('i686' 'x86_64')
url="http://freeciv.org"
license=('GPL')
-depends=('hicolor-icon-theme' 'sdl2_image' 'sdl2_mixer' 'sdl2_gfx' 'sdl2_ttf')
+depends=('sdl2_image' 'sdl2_mixer' 'sdl2_gfx' 'sdl2_ttf' 'lua53' 'gtk3' 'qt5-base' 'imagemagick')
conflicts=('freeciv')
options=('!libtool')
-install=$_pkgname.install
source=(http://files.freeciv.org/stable/$_pkgname-$pkgver.tar.bz2)
sha256sums=('40db957766acbd49c5af15afd1711da996b6681be7abee3352c5f2539c10c1ce')
build() {
cd "$srcdir"/$_pkgname-$pkgver
- ./configure --prefix=/usr --enable-client=sdl2 --enable-shared --without-ggz-client
+ ./configure --prefix=/usr --enable-client=sdl2 --enable-shared
make
}
package() {
cd "$srcdir"/$_pkgname-$pkgver
make DESTDIR="$pkgdir" install
+ mkdir -p $pkgdir/etc/freeciv
+ mv $pkgdir/usr/etc/freeciv/database.lua $pkgdir/etc/freeciv/database.lua
+ rm -rf $pkgdir/usr/etc/
install -m644 client/org.freeciv.sdl2.desktop "$pkgdir"/usr/share/applications/org.freeciv.sdl2.desktop
}
diff --git a/freeciv.install b/freeciv.install
deleted file mode 100644
index 1a05f573e594..000000000000
--- a/freeciv.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}