summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2021-05-15 20:50:37 +0200
committerFrederic Bezies2021-05-15 20:50:37 +0200
commit78685ec05a7f7df4b401712b2078f5319c09accb (patch)
tree83e799894647b8561230560ff1bbc256de31f8c4
downloadaur-78685ec05a7f7df4b401712b2078f5319c09accb.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
-rw-r--r--freeciv.install11
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9332827dbb33
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = freeciv-sdl2
+ pkgdesc = A multiuser clone of the famous Microprose game of Civilization - SDL2 Client
+ pkgver = 2.6.4
+ pkgrel = 1
+ url = http://freeciv.org
+ install = freeciv.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = hicolor-icon-theme
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = sdl2_gfx
+ depends = sdl2_ttf
+ conflicts = freeciv
+ options = !libtool
+ source = http://files.freeciv.org/stable/freeciv-2.6.4.tar.bz2
+ sha256sums = 40db957766acbd49c5af15afd1711da996b6681be7abee3352c5f2539c10c1ce
+
+pkgname = freeciv-sdl2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5b37f7aac67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: Israel Herraiz <isra@herraiz.org>
+# Contributor: jorge_barroso <jorge.barroso.11@gmail.com>
+# Contributor: Ray Griffin <rorgoroth@googlemail.com>
+# Contributor: Jonathan Wiersma <arch aur at jonw dot org>
+
+pkgname=freeciv-sdl2
+_pkgname=freeciv
+pkgver=2.6.4
+pkgrel=1
+pkgdesc="A multiuser clone of the famous Microprose game of Civilization - SDL2 Client"
+arch=('i686' 'x86_64')
+url="http://freeciv.org"
+license=('GPL')
+depends=('hicolor-icon-theme' 'sdl2_image' 'sdl2_mixer' 'sdl2_gfx' 'sdl2_ttf')
+conflicts=('freeciv')
+options=('!libtool')
+install=$_pkgname.install
+source=(http://files.freeciv.org/stable/$_pkgname-$pkgver.tar.bz2)
+sha256sums=('40db957766acbd49c5af15afd1711da996b6681be7abee3352c5f2539c10c1ce')
+
+build() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ ./configure --prefix=/usr --enable-client=sdl2 --enable-shared --without-ggz-client
+ make
+}
+
+package() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -m644 client/org.freeciv.sdl2.desktop "$pkgdir"/usr/share/applications/org.freeciv.sdl2.desktop
+}
+
+
diff --git a/freeciv.install b/freeciv.install
new file mode 100644
index 000000000000..1a05f573e594
--- /dev/null
+++ b/freeciv.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}