summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEinhard Leichtfuß2018-03-25 16:42:32 +0200
committerEinhard Leichtfuß2018-03-25 16:42:32 +0200
commit2af5c2655e139a3590dbe9819ef9aebc98a158af (patch)
tree4f89cec509c8564d2ee4c5e5fe133cadb15385ce
parent26aa75eb4feabae73f5fc7f41fafdfa4d8d865ce (diff)
downloadaur-2af5c2655e139a3590dbe9819ef9aebc98a158af.tar.gz
Change upstream url
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7fcbe497717..a478f85fee08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = freedict-tools-svn
pkgdesc = Tools to compile the Freedict dictionaries
- pkgver = r1629
+ pkgver = r141
pkgrel = 1
+ epoch = 1
url = http://www.freedict.org/
arch = any
license = GPL
@@ -10,7 +11,7 @@ pkgbase = freedict-tools-svn
makedepends = subversion
provides = freedict-tools
conflicts = freedict-tools
- source = svn+https://github.com/freedict/fd-dictionaries/trunk/tools
+ source = svn+https://github.com/freedict/tools/trunk
source = https://raw.githubusercontent.com/freedict/fd-dictionaries/master/README.md
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 310a852e2a0f..d880495c3545 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Einhard Leichtfuß <archer@respiranto.de>
+# Maintainer: Einhard Leichtfuß <alguien@respiranto.de>
_pkgname=freedict-tools
pkgname=${_pkgname}-svn
-pkgver=r1629
+epoch=1
+pkgver=r141
pkgrel=1
pkgdesc="Tools to compile the Freedict dictionaries"
arch=('any')
@@ -10,13 +11,13 @@ license=('GPL' 'GPL3' 'CC-BY-SA')
makedepends=('subversion')
provides=(${_pkgname})
conflicts=(${_pkgname})
-source=("svn+https://github.com/freedict/fd-dictionaries/trunk/tools"
+source=("svn+https://github.com/freedict/tools/trunk"
"https://raw.githubusercontent.com/freedict/fd-dictionaries/master/README.md")
md5sums=('SKIP' 'SKIP')
pkgver()
{
- cd "tools"
+ cd trunk
local _ver="$(svnversion)"
printf "r%s" "${_ver//[[:alpha:]]}"
}
@@ -24,11 +25,11 @@ pkgver()
package()
{
mkdir -p "${pkgdir}/usr/lib/${_pkgname}"
- cp -r tools/. "${pkgdir}/usr/lib/${_pkgname}/"
+ cp -r trunk/. "${pkgdir}/usr/lib/${_pkgname}/"
mkdir -p "${pkgdir}/usr/share/doc/freedict"
cp README.md "${pkgdir}/usr/share/doc/freedict/"
mkdir -p "${pkgdir}/usr/share/doc/freedict/tools"
- cp tools/README.md "${pkgdir}/usr/share/doc/freedict/tools/"
+ cp trunk/README.md "${pkgdir}/usr/share/doc/freedict/tools/"
}