summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreomanis2019-03-30 22:28:52 +0100
committereomanis2019-03-30 22:28:52 +0100
commit7c60c7585fee13bf11a0096404966a2c6a9e3073 (patch)
tree891e9e27295f213bf0a064849da88a6a49bc281c
parente637515012502828c7398fe47109a010b8f61e02 (diff)
downloadaur-7c60c7585fee13bf11a0096404966a2c6a9e3073.tar.gz
Update to version 0.5.2
-rw-r--r--.SRCINFO6
-rwxr-xr-xPKGBUILD12
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82cd1cae9c3a..89dd145b317e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = freedns-maintain-ip
pkgdesc = DNS record updater for freedns.afraid.org domains written in bash
- pkgver = 0.5.1
+ pkgver = 0.5.2
pkgrel = 1
url = http://eomanis.mooo.com/permshare/freedns-maintain-ip/index.xhtml
arch = any
@@ -14,8 +14,8 @@ pkgbase = freedns-maintain-ip
depends = iproute2
depends = bc
optdepends = miniupnpc: Detection of public IPv4 address using UPnP
- source = http://eomanis.mooo.com/permshare/freedns-maintain-ip/freedns-maintain-ip-0.5.1.tar.gz
- sha384sums = 175472faf6e167b0bea65f6db22cc3c347badd7ce9fd7c638670098e1af42cb272597d8f8a512ff57a1304c31c2189c0
+ source = http://eomanis.mooo.com/permshare/freedns-maintain-ip/freedns-maintain-ip-0.5.2.tar.gz
+ sha384sums = 5b4465329252468e4f8a38db0d4fed6de4d22526e94ec14950e1a8ede2eb06ac95f46db404ce95500f7ff43f31620515
pkgname = freedns-maintain-ip
diff --git a/PKGBUILD b/PKGBUILD
index ce3cb5984dd9..958cdf7771e7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: eomanis at web dot de
pkgname='freedns-maintain-ip'
-pkgverUpstream="0.5.1"
+pkgverUpstream="0.5.2"
pkgver="${pkgverUpstream//-/.}"
pkgrel=1
pkgdesc="DNS record updater for freedns.afraid.org domains written in bash"
@@ -11,26 +11,28 @@ license=('GPL3')
depends=('bash>=4.4' 'grep' 'sed' 'wget' 'bind-tools' 'coreutils' 'iproute2' 'bc')
optdepends=('miniupnpc: Detection of public IPv4 address using UPnP')
source=("http://eomanis.mooo.com/permshare/freedns-maintain-ip/freedns-maintain-ip-${pkgverUpstream}.tar.gz")
-sha384sums=('175472faf6e167b0bea65f6db22cc3c347badd7ce9fd7c638670098e1af42cb272597d8f8a512ff57a1304c31c2189c0')
+sha384sums=('5b4465329252468e4f8a38db0d4fed6de4d22526e94ec14950e1a8ede2eb06ac95f46db404ce95500f7ff43f31620515')
package() {
+ srcRootDir="${srcdir}/${pkgname}-${pkgverUpstream}"
+
# Place the main bash script into /usr/bin
mkdir -p "${pkgdir}/usr/bin"
cd "${pkgdir}/usr/bin"
- cp -t . "${srcdir}/freedns-maintain-ip"
+ cp -t . "${srcRootDir}/freedns-maintain-ip"
chmod u=rwx,go=rx "freedns-maintain-ip"
# Place the systemd unit file into /usr/lib/systemd/system
mkdir -p "${pkgdir}/usr/lib/systemd/system"
cd "${pkgdir}/usr/lib/systemd/system"
- cp -t . "${srcdir}/freedns-maintain-ip@.service"
+ cp -t . "${srcRootDir}/freedns-maintain-ip@.service"
chmod u=rw,go=r "freedns-maintain-ip@.service"
# Gzip and place the manual page
mkdir -p "${pkgdir}/usr/share/man"
cd "${pkgdir}/usr/share/man"
mkdir "man8"
- gzip --fast --to-stdout - < "${srcdir}/freedns-maintain-ip.8" > "man8/freedns-maintain-ip.8.gz"
+ gzip --fast --to-stdout - < "${srcRootDir}/freedns-maintain-ip.8" > "man8/freedns-maintain-ip.8.gz"
chmod -R u=rwX,go=rX .
}