summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreomanis2018-05-07 01:11:40 +0200
committereomanis2018-05-07 01:11:40 +0200
commit8d961db4ac9a01819feb71ddc0086dea33f236ed (patch)
treee26715a1b16918912e068d75e24acad11a33009f
downloadaur-8d961db4ac9a01819feb71ddc0086dea33f236ed.tar.gz
Initial commit, freedns-maintain-ip 0.1.0
-rw-r--r--.SRCINFO18
-rwxr-xr-xPKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64e3fa30c0df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = freedns-maintain-ip
+ pkgdesc = DNS record updater for freedns.afraid.org domains written in bash
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = http://eomanis.mooo.com/permshare/freedns-maintain-ip/index.xhtml
+ arch = any
+ license = GPL3
+ depends = bash
+ depends = sed
+ depends = miniupnpc
+ depends = wget
+ depends = bind-tools
+ depends = coreutils
+ source = http://eomanis.mooo.com/permshare/freedns-maintain-ip/freedns-maintain-ip-0.1.0.tar.gz
+ sha256sums = d3e4e6d5691643de14aa0186f3571fe48163ed11a1985ad85ccd452c3da7e2a2
+
+pkgname = freedns-maintain-ip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..4492c00dfb7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: eomanis at web dot de
+
+pkgname='freedns-maintain-ip'
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="DNS record updater for freedns.afraid.org domains written in bash"
+arch=('any')
+url='http://eomanis.mooo.com/permshare/freedns-maintain-ip/index.xhtml'
+license=('GPL3')
+depends=('bash' 'sed' 'miniupnpc' 'wget' 'bind-tools' 'coreutils')
+source=("http://eomanis.mooo.com/permshare/freedns-maintain-ip/freedns-maintain-ip-${pkgver}.tar.gz")
+sha256sums=('d3e4e6d5691643de14aa0186f3571fe48163ed11a1985ad85ccd452c3da7e2a2')
+
+package() {
+
+ # Place the main bash script into /usr/bin
+ mkdir -p "${pkgdir}/usr/bin"
+ cd "${pkgdir}/usr/bin"
+ cp -t . "${srcdir}/freedns-maintain-ip"
+ chmod u=rwx,go=rx "freedns-maintain-ip"
+
+ # Place the systemd unit file into /usr/lib/systemd/system
+ mkdir -p "${pkgdir}/usr/lib/systemd/system"
+ cd "${pkgdir}/usr/lib/systemd/system"
+ cp -t . "${srcdir}/freedns-maintain-ip@.service"
+ chmod u=rw,go=r "freedns-maintain-ip@.service"
+
+ # Gzip and place the manual page
+ mkdir -p "${pkgdir}/usr/share/man"
+ cd "${pkgdir}/usr/share/man"
+ mkdir "man8"
+ gzip --fast --to-stdout - < "${srcdir}/freedns-maintain-ip.8" > "man8/freedns-maintain-ip.8.gz"
+ chmod -R u=rwX,go=rX .
+}