summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Brulhart2019-02-11 23:38:19 +0100
committerSimon Brulhart2019-02-12 00:12:57 +0100
commit29f208b34b3dc5f9af3e5ec9f56e2d89d2c2b25d (patch)
treee855dbf8df59860f6e23e75d601a0a00ae8a3bc8
parent95843a2f821bc6bcd902684e72b0c06137990c3d (diff)
downloadaur-29f208b34b3dc5f9af3e5ec9f56e2d89d2c2b25d.tar.gz
Remove obselete workarounds
-rw-r--r--PKGBUILD15
1 files changed, 0 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d8a137687fa..1f0160747b24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,23 +32,12 @@ DLAGENTS=('https::/usr/bin/curl -fLC - --retry 5 --retry-delay 3 -A Mozilla -o %
prepare() {
# wxgtk < 3.1.0
- sed -i 's/m_listBoxHistory->GetTopItem()/0/g' FreeFileSync/Source/ui/main_dlg.cpp
# Revert to classic config path
patch --binary -p1 -i revert_xdg_config_path.patch
# Revert change to resources path of portable version
patch --binary -p1 -i revert_resources_path.patch
-# gcc 6.3.1
- sed -i 's!static_assert!//static_assert!' zen/scope_guard.h
-
-# warn_static(string)
- sed -i 's!-O3 -DN!-D"warn_static(arg)= " -O3 -DN!' FreeFileSync/Source/Makefile
- sed -i 's!-O3 -DN!-D"warn_static(arg)= " -O3 -DN!' FreeFileSync/Source/RealTimeSync/Makefile
-
-# install error
- cp ${srcdir}/Changelog.txt ${srcdir}/FreeFileSync/Build
-
# edit lines to remove functions that require wxgtk 3.1.x
sed -e 's:m_textCtrlOfflineActivationKey->ForceUpper:// &:g' -i 'FreeFileSync/Source/ui/small_dlgs.cpp'
sed -e 's:const double scrollSpeed =:& 6; //:g' -i 'wx+/grid.cpp'
@@ -56,9 +45,6 @@ prepare() {
# add '-lz' back into LINKFLAGS
sed -i '/pie/ s/-pthread/-lz -pthread/' FreeFileSync/Source/Makefile
sed -i '/pie/ s/-pthread/-lz -pthread/' FreeFileSync/Source/RealTimeSync/Makefile
-
-# file not found error
- sed -i '/\t"..\/Build\/User Manual.pdf" \\/d' FreeFileSync/Source/Makefile
# inlining of constants not present in libssh2's distributed headers
sed -i 's/MAX_SFTP_READ_SIZE/30000/g' FreeFileSync/Source/fs/sftp.cpp
@@ -75,7 +61,6 @@ build() {
echo "compiler g++ $VER $MAC"
### FFS
- mkdir -p "${srcdir}/FreeFileSync/Build/Bin"
cd "${srcdir}/FreeFileSync/Source"
make EXENAME=FreeFileSync TMP_PATH="${srcdir}/FreeFileSync/tmp_ffs"