summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNori132018-03-11 15:48:46 -0600
committerNori132018-03-11 15:48:46 -0600
commit3878e403dc856fee917a0526021b5dba47a8a784 (patch)
tree104ece4094eff128a2790a93aa209fc48fa62da4
parent6822f7aecb7e53e0e6dcf283f3127430342f69f9 (diff)
downloadaur-3878e403dc856fee917a0526021b5dba47a8a784.tar.gz
Updated to version <ver>
-rwxr-xr-x.SRCINFO12
-rw-r--r--[-rwxr-xr-x]PKGBUILD14
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7dc63a00f081..28c73246a41b 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
pkgbase = freefilesync
pkgdesc = Backup software to synchronize files and folders
- pkgver = 9.8
- pkgrel = 1
+ pkgver = 9.9
+ pkgrel = 0
url = http://www.freefilesync.org/
arch = i686
arch = x86_64
license = GPLv3
makedepends = boost
- depends = wxgtk
+ depends = wxgtk-common-dev
+ depends = wxgtk2-dev
+ depends = wxgtk3-dev
depends = webkit2gtk
depends = boost-libs
- source = FreeFileSync_9.8_Source.zip::https://www.freefilesync.org/download_redirect.php?file=FreeFileSync_9.8_Source.zip
+ source = FreeFileSync_9.9_Source.zip::https://doc-14-a8-docs.googleusercontent.com/docs/securesc/ha0ro937gcuc7l7deffksulhg5h7mbp1/b6kbcbhg0cvom3hp3v8al83rk0lb2uqc/1520798400000/06806984287875468759/*/1v9WRaJGYqloH_U_ywDk10Jzqt7lGA9Vo?e=download
source = FreeFileSync.desktop
source = ffsicon.png
source = RealTimeSync.desktop
source = rtsicon.png
- sha256sums = 77a59586284a518d6df6c0cc934c3efa434f247acce70452ab9fe37e7747b96d
+ sha256sums = 1ba04b3c3f86865c2e429afa1614f40a9108d4bef99404416df3e0bf49b74281
sha256sums = b381bb9dbda25c3c08a67f18072a2761abe34339ddf3318e1758eb7c349f1a3b
sha256sums = 31df3fa1f1310de14bbd379f891d4f8ed2df5b0d68913eb52c88b3be682933fb
sha256sums = 1502efdbf1638856a18ab9916e0431bf6a53471792cb2daa380345bac33f67c4
diff --git a/PKGBUILD b/PKGBUILD
index 6cccb9986242..780acb693bc9 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,16 @@
# Maintainer: alexmo82 <25396682 AT live DOT it>
pkgname=freefilesync
-pkgver=9.8
-pkgrel=1
+pkgver=9.9
+pkgrel=0
pkgdesc="Backup software to synchronize files and folders"
arch=('i686' 'x86_64')
url="http://www.freefilesync.org/"
license=('GPLv3')
-depends=(wxgtk webkit2gtk boost-libs)
+depends=(wxgtk-common-dev wxgtk2-dev wxgtk3-dev webkit2gtk boost-libs)
makedepends=(boost)
source=(
- "FreeFileSync_${pkgver}_Source.zip::https://www.freefilesync.org/download_redirect.php?file=FreeFileSync_${pkgver}_Source.zip" #ffs
+ "FreeFileSync_${pkgver}_Source.zip::https://doc-14-a8-docs.googleusercontent.com/docs/securesc/ha0ro937gcuc7l7deffksulhg5h7mbp1/b6kbcbhg0cvom3hp3v8al83rk0lb2uqc/1520798400000/06806984287875468759/*/1v9WRaJGYqloH_U_ywDk10Jzqt7lGA9Vo?e=download" #ffs
FreeFileSync.desktop
ffsicon.png
RealTimeSync.desktop
@@ -21,17 +21,17 @@ source=(
)
sha256sums=(
- '77a59586284a518d6df6c0cc934c3efa434f247acce70452ab9fe37e7747b96d' #ffs source
+ '1ba04b3c3f86865c2e429afa1614f40a9108d4bef99404416df3e0bf49b74281' #ffs source
'b381bb9dbda25c3c08a67f18072a2761abe34339ddf3318e1758eb7c349f1a3b' #FreeFileSync.desktop
'31df3fa1f1310de14bbd379f891d4f8ed2df5b0d68913eb52c88b3be682933fb' #ffsicon.png
'1502efdbf1638856a18ab9916e0431bf6a53471792cb2daa380345bac33f67c4' #RealTimeSync.desktop
'f28042587dbe99cf5d6bef2c1be4b026488e418e4ba8332b3016d246b7053a4e' #rtsicon.png
)
-DLAGENTS=('https::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -A Mozilla -o %o %u')
+# DLAGENTS=('https::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -A Mozilla -o %o %u')
prepare() {
-# wxgtk < 3.1.0
+# wxgtk >= 3.1.0
sed -i 's/m_listBoxHistory->GetTopItem()/0/g' FreeFileSync/Source/ui/main_dlg.cpp
# gcc 6.3.1