summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralexmo822017-06-06 01:01:23 +0200
committeralexmo822017-06-06 01:01:23 +0200
commitb4790f410a8653991ce2b716cdd5247234312ca3 (patch)
treedec7955ece62f3aef6c25b5e1ba9c7dea0ad0f8f
parent6fc805b5ea6147084d1743496b09cd6a833c74d8 (diff)
downloadaur-b4790f410a8653991ce2b716cdd5247234312ca3.tar.gz
Update to 9.1
-rwxr-xr-x.SRCINFO10
-rwxr-xr-xPKGBUILD46
2 files changed, 29 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ee11a13606b..81dd9ec63843 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Feb 13 00:58:06 UTC 2017
+# Mon Jun 5 23:01:14 UTC 2017
pkgbase = freefilesync
pkgdesc = Backup software to synchronize files and folders
- pkgver = 8.9
+ pkgver = 9.1
pkgrel = 0
url = http://www.freefilesync.org/
arch = i686
@@ -12,14 +12,12 @@ pkgbase = freefilesync
depends = wxgtk
depends = webkitgtk2
depends = boost-libs
- source = http://downloads.sourceforge.net/project/zenxml/zenXml_2.4.zip
- source = FreeFileSync_8.9_Source.zip::https://dl.dropboxusercontent.com/u/74545385/FreeFileSync_8.9_Source.zip
+ source = FreeFileSync_9.1_Source.zip::https://www.freefilesync.org/download_redirect.php?file=FreeFileSync_9.1_Source.zip
source = FreeFileSync.desktop
source = ffsicon.png
source = RealTimeSync.desktop
source = rtsicon.png
- md5sums = 55907f1af4eb94a4196d95815b675d78
- md5sums = 92a29624a517367e348afce669502c73
+ md5sums = 362eb9c7bfb8638119a8ba7a75c99fa4
md5sums = eab0ccfc6a88e229a0f07507b93cfcff
md5sums = 1f452dff6f970d95839411008d86250b
md5sums = ab266177f69d16ad9f4099ae4edd77a2
diff --git a/PKGBUILD b/PKGBUILD
index 1f90c368d652..f651e8bfe810 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: alexmo82 <25396682 AT live DOT it>
pkgname=freefilesync
-pkgver=8.9
+pkgver=9.1
pkgrel=0
pkgdesc="Backup software to synchronize files and folders"
arch=('i686' 'x86_64')
@@ -12,16 +12,14 @@ license=('GPLv3')
depends=(wxgtk webkitgtk2 boost-libs)
makedepends=(boost)
source=(
- "http://downloads.sourceforge.net/project/zenxml/zenXml_2.4.zip" #zen
- "FreeFileSync_${pkgver}_Source.zip::https://dl.dropboxusercontent.com/u/74545385/FreeFileSync_8.9_Source.zip" #ffs
+ "FreeFileSync_${pkgver}_Source.zip::https://www.freefilesync.org/download_redirect.php?file=FreeFileSync_${pkgver}_Source.zip" #ffs
FreeFileSync.desktop
ffsicon.png
RealTimeSync.desktop
rtsicon.png
)
md5sums=(
- '55907f1af4eb94a4196d95815b675d78' #zen source
- '92a29624a517367e348afce669502c73' #ffs source
+ '362eb9c7bfb8638119a8ba7a75c99fa4' #ffs source
'eab0ccfc6a88e229a0f07507b93cfcff' #FreeFileSync.desktop
'1f452dff6f970d95839411008d86250b' #ffsicon.png
'ab266177f69d16ad9f4099ae4edd77a2' #RealTimeSync.desktop
@@ -31,28 +29,34 @@ md5sums=(
prepare() {
# wxgtk < 3.1.0
sed -i 's/m_listBoxHistory->GetTopItem()/0/g' FreeFileSync/Source/ui/main_dlg.cpp
+
# gcc 6.3.1
- sed -i 's!static_assert!//static_assert!' zen/scope_guard.h
-# 8.9 warn_static(string) -DZEN_LINUX
- sed -i 's!-O3 -DN!-D"warn_static(arg)= " -DZEN_LINUX -O3 -DN!' FreeFileSync/Source/Makefile
- sed -i 's!-O3 -DN!-D"warn_static(arg)= " -DZEN_LINUX -O3 -DN!' FreeFileSync/Source/RealTimeSync/Makefile
-# 8.9 linker error
+# sed -i 's!static_assert!//static_assert!' zen/scope_guard.h
+
+# warn_static(string)
+ sed -i 's!-O3 -DN!-D"warn_static(arg)= " -O3 -DN!' FreeFileSync/Source/Makefile
+ sed -i 's!-O3 -DN!-D"warn_static(arg)= " -O3 -DN!' FreeFileSync/Source/RealTimeSync/Makefile
+
+# linker error
sed -i 's#inline##g' FreeFileSync/Source/ui/version_check_impl.h
-# 8.9 install error
+
+# install error
cp ${srcdir}/Changelog.txt ${srcdir}/FreeFileSync/Build
}
build() {
-# just in case of compile errors
- VER=`g++ -dumpversion`
- MAC=`g++ -dumpmachine`
- echo "compiler g++ $VER $MAC"
-# FFS
- cd ${srcdir}/FreeFileSync/Source
- make launchpad
-# RTS
- cd RealTimeSync
- make launchpad
+### just in case of compile errors
+ VER=`g++ -dumpversion`
+ MAC=`g++ -dumpmachine`
+ echo "compiler g++ $VER $MAC"
+
+### FFS
+ cd ${srcdir}/FreeFileSync/Source
+ make launchpad
+
+### RTS
+ cd RealTimeSync
+ make launchpad
}
package() {