summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Brulhart2019-08-17 20:05:54 +0200
committerSimon Brulhart2019-08-17 20:10:19 +0200
commitdd232907bb628ae2a41e6f955e49af5d28418623 (patch)
tree1bd4a253009c8483f82aaab3a82dcd4b2cb969aa
parent9c8f6f84685763b18757a9c5261c5291d53fe640 (diff)
downloadaur-dd232907bb628ae2a41e6f955e49af5d28418623.tar.gz
Update to v10.15
-rwxr-xr-x.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--revert_bulk_append.patch26
-rw-r--r--revert_linkflags.patch36
4 files changed, 80 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 461b0af69808..3d7c4e0fdcff 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = freefilesync
pkgdesc = Backup software to synchronize files and folders
- pkgver = 10.14
+ pkgver = 10.15
pkgrel = 1
url = https://freefilesync.org
arch = i686
@@ -11,12 +11,16 @@ pkgbase = freefilesync
depends = wxgtk
depends = webkit2gtk
depends = boost-libs
- source = FreeFileSync_10.14_Source.zip::https://freefilesync.org/download/FreeFileSync_10.14_Source.zip
+ source = FreeFileSync_10.15_Source.zip::https://freefilesync.org/download/FreeFileSync_10.15_Source.zip
source = revert_xdg_config_path.patch
+ source = revert_bulk_append.patch
+ source = revert_linkflags.patch
source = FreeFileSync.desktop
source = RealTimeSync.desktop
- sha256sums = 93bc5a2c6f83e516a1827787c893c80ede83566b4ac47ca7f75cf83204a4987a
+ sha256sums = bf495c182c51565a622023e4823a8df0a912c73f134e57a7398ccb6578d46dc5
sha256sums = e74b4abdf04c58004e52f77afee762e4c3d72d4ca42de4cc42cbc930cbec0e32
+ sha256sums = 2ea1f157ab31feb18b0d8ac117a1820174a4b2b9bdaee2027c1fbc2c287e1caa
+ sha256sums = d3dedc100163ce00ae5889a6039a1fff11ae32b676ae5e83ae9182509f80638d
sha256sums = 590d87707240529ca893199f852143f5d7c7266cb050e37e615900b013ac3d51
sha256sums = 82439b4b81b0a72652befad9b9db52ffbc0180f307c92205aa5ab344f9f82830
diff --git a/PKGBUILD b/PKGBUILD
index bf6726610182..f39ff0c4a680 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Maintainer: jooch <jooch AT gmx DOT com>
pkgname=freefilesync
-pkgver=10.14
+pkgver=10.15
pkgrel=1
pkgdesc="Backup software to synchronize files and folders"
arch=('i686' 'x86_64')
@@ -16,27 +16,30 @@ makedepends=(boost unzip)
source=(
"FreeFileSync_${pkgver}_Source.zip::${url}/download/FreeFileSync_${pkgver}_Source.zip" #ffs
revert_xdg_config_path.patch
+ revert_bulk_append.patch
+ revert_linkflags.patch
FreeFileSync.desktop
RealTimeSync.desktop
)
-sha256sums=('93bc5a2c6f83e516a1827787c893c80ede83566b4ac47ca7f75cf83204a4987a'
+sha256sums=('bf495c182c51565a622023e4823a8df0a912c73f134e57a7398ccb6578d46dc5'
'e74b4abdf04c58004e52f77afee762e4c3d72d4ca42de4cc42cbc930cbec0e32'
+ '2ea1f157ab31feb18b0d8ac117a1820174a4b2b9bdaee2027c1fbc2c287e1caa'
+ 'd3dedc100163ce00ae5889a6039a1fff11ae32b676ae5e83ae9182509f80638d'
'590d87707240529ca893199f852143f5d7c7266cb050e37e615900b013ac3d51'
'82439b4b81b0a72652befad9b9db52ffbc0180f307c92205aa5ab344f9f82830')
DLAGENTS=("https::/usr/bin/curl -fLC - --retry 5 --retry-delay 3 -A Mozilla -o %o %u")
-_auth_request="$(\
- echo "Authenticating for download ..." >&2; \
- /usr/bin/curl -fsSL -A Mozilla "$url/cookie/init.js.php" \
-)"
prepare() {
# wxgtk < 3.1.0
# Revert to classic config path
patch --binary -p1 -i revert_xdg_config_path.patch
+ # Avoid uses of wxItemContainer::Append(const std::vector<wxString>& items)
+ patch --binary -p1 -i revert_bulk_append.patch
+
# edit lines to remove functions that require wxgtk 3.1.x
sed -e 's:m_textCtrlOfflineActivationKey->ForceUpper:// &:g' -i 'FreeFileSync/Source/ui/small_dlgs.cpp'
sed -e 's:const double scrollSpeed =:& 6; //:g' -i 'wx+/grid.cpp'
@@ -44,9 +47,8 @@ prepare() {
# libssh2 v1.8.2 does not yet implement LIBSSH2_SFTP_DEFAULT_MODE, revert to previous impl.
sed -e 's/LIBSSH2_SFTP_DEFAULT_MODE/LIBSSH2_SFTP_S_IRWXU | LIBSSH2_SFTP_S_IRWXG | LIBSSH2_SFTP_S_IRWXO/g' -i 'FreeFileSync/Source/afs/sftp.cpp'
-# add '-lz' back into LINKFLAGS
- sed -i '/pie/ s/-pthread/-lz -pthread/' FreeFileSync/Source/Makefile
- sed -i '/pie/ s/-pthread/-lz -pthread/' FreeFileSync/Source/RealTimeSync/Makefile
+# add LINKFLAGS that were removed but that we still need in our case
+ patch -p1 -i revert_linkflags.patch
# inlining of constants not present in libssh2's distributed headers
sed -i 's/MAX_SFTP_READ_SIZE/30000/g' FreeFileSync/Source/afs/sftp.cpp
diff --git a/revert_bulk_append.patch b/revert_bulk_append.patch
new file mode 100644
index 000000000000..a9ed6058fe51
--- /dev/null
+++ b/revert_bulk_append.patch
@@ -0,0 +1,26 @@
+diff -r -u a/FreeFileSync/Source/ui/command_box.cpp b/FreeFileSync/Source/ui/command_box.cpp
+--- a/FreeFileSync/Source/ui/command_box.cpp 2019-08-15 19:36:52.000000000 +0200
++++ b/FreeFileSync/Source/ui/command_box.cpp 2019-08-17 19:08:51.511285343 +0200
+@@ -130,7 +130,8 @@
+
+ //this->Clear(); -> NO! emits yet another wxEVT_COMMAND_TEXT_UPDATED!!!
+ wxItemContainer::Clear(); //suffices to clear the selection items only!
+- this->Append(items);
++ for (const wxString& item : items)
++ this->Append(item);
+
+ //this->SetSelection(wxNOT_FOUND); //don't select anything
+ ChangeValue(value); //preserve main text!
+diff -r -u a/FreeFileSync/Source/ui/folder_history_box.cpp b/FreeFileSync/Source/ui/folder_history_box.cpp
+--- a/FreeFileSync/Source/ui/folder_history_box.cpp 2019-08-15 19:36:52.000000000 +0200
++++ b/FreeFileSync/Source/ui/folder_history_box.cpp 2019-08-17 19:04:37.023593558 +0200
+@@ -90,7 +90,8 @@
+
+ //this->Clear(); -> NO! emits yet another wxEVT_COMMAND_TEXT_UPDATED!!!
+ wxItemContainer::Clear(); //suffices to clear the selection items only!
+- this->Append(dirList);
++ for (const wxString& dir : dirList)
++ this->Append(dir);
+
+ //this->SetSelection(wxNOT_FOUND); //don't select anything
+ ChangeValue(folderPathPhrase); //preserve main text!
diff --git a/revert_linkflags.patch b/revert_linkflags.patch
new file mode 100644
index 000000000000..e2e9261397f5
--- /dev/null
+++ b/revert_linkflags.patch
@@ -0,0 +1,36 @@
+diff -r -u FreeFileSync_10.15_Source/FreeFileSync/Source/Makefile src/FreeFileSync/Source/Makefile
+--- FreeFileSync_10.15_Source/FreeFileSync/Source/Makefile 2019-08-15 19:36:51.000000000 +0200
++++ src/FreeFileSync/Source/Makefile 2019-08-17 19:44:59.706615730 +0200
+@@ -4,7 +4,7 @@
+ -Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
+ -O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
+
+-LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -pthread
++LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
+
+
+ CXXFLAGS += `pkg-config --cflags openssl`
+@@ -17,6 +17,7 @@
+ LINKFLAGS += `pkg-config --libs libssh2`
+
+ CXXFLAGS += `pkg-config --cflags gtk+-2.0`
++LINKFLAGS += `pkg-config --libs gtk+-2.0`
+ #treat as system headers so that warnings are hidden:
+ CXXFLAGS += -isystem/usr/include/gtk-2.0
+
+diff -r -u FreeFileSync_10.15_Source/FreeFileSync/Source/RealTimeSync/Makefile src/FreeFileSync/Source/RealTimeSync/Makefile
+--- FreeFileSync_10.15_Source/FreeFileSync/Source/RealTimeSync/Makefile 2019-08-15 19:36:51.000000000 +0200
++++ src/FreeFileSync/Source/RealTimeSync/Makefile 2019-08-17 19:45:29.529715592 +0200
+@@ -4,10 +4,11 @@
+ -Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
+ -O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
+
+-LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -pthread
++LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
+
+ #Gtk - support "no button border"
+ CXXFLAGS += `pkg-config --cflags gtk+-2.0`
++LINKFLAGS += `pkg-config --libs gtk+-2.0`
+ #treat as system headers so that warnings are hidden:
+ CXXFLAGS += -isystem/usr/include/gtk-2.0
+ \ No newline at end of file