diff options
author | archibald869 | 2019-02-21 20:57:56 +0100 |
---|---|---|
committer | archibald869 | 2019-02-21 20:57:56 +0100 |
commit | 05d23706ea682b66771ad23aecf1ed18d8409a57 (patch) | |
tree | 11c1f6b1af52f675f39396a3d0d1ad93d1dc4818 | |
parent | 353a1e2e86d03783d779fd27036aa1052d3c694a (diff) | |
download | aur-05d23706ea682b66771ad23aecf1ed18d8409a57.tar.gz |
Fix download issue by using previously used URL and Referer header
-rw-r--r-- | .SRCINFO | 4 | ||||
-rw-r--r-- | .gitignore | 1 | ||||
-rw-r--r-- | Makefile | 16 | ||||
-rw-r--r-- | PKGBUILD | 7 |
4 files changed, 23 insertions, 5 deletions
@@ -1,7 +1,7 @@ pkgbase = freefilesync-bin pkgdesc = Folder comparison and synchronization pkgver = 10.9 - pkgrel = 2 + pkgrel = 3 url = https://www.freefilesync.org/ arch = i686 arch = x86_64 @@ -14,7 +14,7 @@ pkgbase = freefilesync-bin provides = freefilesync conflicts = freefilesync options = !strip - source = freefilesync-bin-10.9.tar.gz::https://freefilesync.org/download_redirect.php?file=FreeFileSync_10.9_Linux.tar.gz + source = freefilesync-bin-10.9.tar.gz::https://freefilesync.org/download/FreeFileSync_10.9_Linux.tar.gz source = FreeFileSync.desktop source = FreeFileSync.png source = RealTimeSync.desktop diff --git a/.gitignore b/.gitignore index 520a12c87615..1742d0b51c73 100644 --- a/.gitignore +++ b/.gitignore @@ -2,3 +2,4 @@ /src/ *.tar.gz *.tar.xz +*.part diff --git a/Makefile b/Makefile new file mode 100644 index 000000000000..43a16f77da31 --- /dev/null +++ b/Makefile @@ -0,0 +1,16 @@ +.DEFAULT_GOAL := .SRCINFO +.PHONY: all build install clean + +.SRCINFO: PKGBUILD + makepkg --printsrcinfo > .SRCINFO + +all: build install + +build: PKGBUILD .SRCINFO + makepkg -f + +install: PKGBUILD build + makepkg -i + +clean: + rm -rf pkg src *.tar.gz *.tar.xz *.part @@ -3,7 +3,7 @@ pkgname=freefilesync-bin _pkgname=freefilesync pkgver=10.9 -pkgrel=2 +pkgrel=3 pkgdesc="Folder comparison and synchronization" arch=("i686" "x86_64") url="https://www.freefilesync.org/" @@ -12,7 +12,7 @@ provides=("freefilesync") conflicts=("freefilesync") depends=(gtk2 lib32-fontconfig lib32-libx11 libxxf86vm lib32-libsm) source=( - "${pkgname}-${pkgver}.tar.gz::https://freefilesync.org/download_redirect.php?file=FreeFileSync_${pkgver}_Linux.tar.gz" + "${pkgname}-${pkgver}.tar.gz::https://freefilesync.org/download/FreeFileSync_${pkgver}_Linux.tar.gz" FreeFileSync.desktop FreeFileSync.png RealTimeSync.desktop @@ -26,7 +26,8 @@ sha256sums=( "23c68af45d34f41fdb76886067b71af4dd3fe14f2dd60f73193b2052dc333bf6" ) options=(!strip) -DLAGENTS=("https::/usr/bin/curl -fLC - --retry 5 --retry-delay 3 -A Mozilla -o %o %u") +DLAGENTS=("https::/usr/bin/curl -fLC - --retry 5 --retry-delay 3 \ + -A Mozilla -e 'https://freefilesync.org/download.php;auto' -o %o %u") package() { _pkg=FreeFileSync |