summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchibald8692018-11-14 23:04:02 +0100
committerarchibald8692018-11-14 23:04:02 +0100
commitefca084966e5c773e065491cc65eb1827e77bcd6 (patch)
treec7f6667ca1ba4bd8385ab931e0bb15245f86d670
downloadaur-efca084966e5c773e065491cc65eb1827e77bcd6.tar.gz
Initial commit (v10.6)
-rw-r--r--.SRCINFO28
-rw-r--r--FreeFileSync.desktop17
-rw-r--r--FreeFileSync.pngbin0 -> 34086 bytes
-rw-r--r--PKGBUILD53
-rw-r--r--RealTimeSync.desktop17
-rw-r--r--RealTimeSync.pngbin0 -> 30922 bytes
6 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e7951cb7e24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = freefilesync-bin
+ pkgdesc = Folder comparison and synchronization
+ pkgver = 10.6
+ pkgrel = 1
+ url = https://www.freefilesync.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = gtk2
+ depends = lib32-fontconfig
+ depends = lib32-libx11
+ depends = libxxf86vm
+ depends = lib32-libsm
+ provides = freefilesync
+ conflicts = freefilesync
+ source = freefilesync-bin-10.6.tar.gz::https://freefilesync.org/download/FreeFileSync_10.6_Linux.tar.gz
+ source = FreeFileSync.desktop
+ source = FreeFileSync.png
+ source = RealTimeSync.desktop
+ source = RealTimeSync.png
+ sha256sums = dd1461f846ff71d66d418f26c59120ee6d895f2f01caaf99fc31838f69e8c8fc
+ sha256sums = 461f7deb9245bbcaf281160945ec800e54a703068220d0d239de6dddccad0de3
+ sha256sums = b2fac3b8c0badfbbbcf605ecad5b184f2c9918bd0dd14596e6c43df3f2a76a30
+ sha256sums = 36a6b962cb5c1cd2c453d1bddaab915b1764614b207ae7f5b3694acf5740940c
+ sha256sums = 23c68af45d34f41fdb76886067b71af4dd3fe14f2dd60f73193b2052dc333bf6
+
+pkgname = freefilesync-bin
+
diff --git a/FreeFileSync.desktop b/FreeFileSync.desktop
new file mode 100644
index 000000000000..5b1c76366296
--- /dev/null
+++ b/FreeFileSync.desktop
@@ -0,0 +1,17 @@
+[Desktop Entry]
+Name=FreeFileSync
+GenericName=File synchronization
+GenericName[de_DE]=Dateisynchronisation
+Comment=Folder comparison and synchronization
+Comment[de_DE]=Vergleich und Synchronisation von Verzeichnissen
+Path=/opt/freefilesync
+Exec=FreeFileSync %f
+Icon=/usr/share/pixmaps/FreeFileSync.png
+NoDisplay=false
+Terminal=false
+TerminalOptions=
+Type=Application
+Categories=Utility;FileTools;GTK;
+StartupNotify=true
+X-KDE-SubstituteUID=false
+X-KDE-Username=
diff --git a/FreeFileSync.png b/FreeFileSync.png
new file mode 100644
index 000000000000..329fa6a981af
--- /dev/null
+++ b/FreeFileSync.png
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..036f128967b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: archibald869 at web dot de
+
+pkgname=freefilesync-bin
+_pkgname=freefilesync
+pkgver=10.6
+pkgrel=1
+pkgdesc="Folder comparison and synchronization"
+arch=("i686" "x86_64")
+url="https://www.freefilesync.org/"
+license=("GPL3")
+provides=("freefilesync")
+conflicts=("freefilesync")
+depends=(gtk2 lib32-fontconfig lib32-libx11 libxxf86vm lib32-libsm)
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://freefilesync.org/download/FreeFileSync_${pkgver}_Linux.tar.gz"
+ FreeFileSync.desktop
+ FreeFileSync.png
+ RealTimeSync.desktop
+ RealTimeSync.png
+)
+sha256sums=(
+ "dd1461f846ff71d66d418f26c59120ee6d895f2f01caaf99fc31838f69e8c8fc"
+ "461f7deb9245bbcaf281160945ec800e54a703068220d0d239de6dddccad0de3"
+ "b2fac3b8c0badfbbbcf605ecad5b184f2c9918bd0dd14596e6c43df3f2a76a30"
+ "36a6b962cb5c1cd2c453d1bddaab915b1764614b207ae7f5b3694acf5740940c"
+ "23c68af45d34f41fdb76886067b71af4dd3fe14f2dd60f73193b2052dc333bf6"
+)
+DLAGENTS=("https::/usr/bin/curl -fLC - --retry 5 --retry-delay 3 -A Mozilla -o %o %u")
+
+package() {
+ _pkg=FreeFileSync
+
+ cd "$srcdir"
+
+ install -d "$pkgdir/opt/$_pkgname"
+ cp -r "$_pkg"/* "$pkgdir/opt/$_pkgname"
+
+ # documentation
+ install -d "$pkgdir/usr/share/doc/$_pkgname"
+ ln -sf "/opt/$_pkgname/User Manual.pdf" "$pkgdir/usr/share/doc/$_pkgname/User_Manual.pdf"
+
+ # license
+ install -d "$pkgdir/usr/share/licenses/$_pkgname"
+ ln -sf "/opt/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+
+ # desktop launcher for FreeFileSync
+ install -Dm644 FreeFileSync.png "$pkgdir/usr/share/pixmaps/FreeFileSync.png"
+ install -Dm644 FreeFileSync.desktop "$pkgdir/usr/share/applications/FreeFileSync.desktop"
+
+ # desktop launcher for RealTimeSync
+ install -Dm644 RealTimeSync.png "$pkgdir/usr/share/pixmaps/RealTimeSync.png"
+ install -Dm644 RealTimeSync.desktop "$pkgdir/usr/share/applications/RealTimeSync.desktop"
+}
diff --git a/RealTimeSync.desktop b/RealTimeSync.desktop
new file mode 100644
index 000000000000..1a5c1c41e338
--- /dev/null
+++ b/RealTimeSync.desktop
@@ -0,0 +1,17 @@
+[Desktop Entry]
+Name=RealTimeSync
+GenericName=Automated Synchronization
+GenericName[de_DE]=Automatisierte Synchronisation
+Comment=Automated folder synchronization
+Comment[de_DE]=Automatisierte Verzeichnis-Synchronisation
+Path=/opt/freefilesync
+Exec=RealTimeSync %f
+Icon=/usr/share/pixmaps/RealTimeSync.png
+NoDisplay=false
+Terminal=false
+TerminalOptions=
+Type=Application
+Categories=Utility;FileTools;GTK;
+StartupNotify=true
+X-KDE-SubstituteUID=false
+X-KDE-Username=
diff --git a/RealTimeSync.png b/RealTimeSync.png
new file mode 100644
index 000000000000..c4dcbf6ada79
--- /dev/null
+++ b/RealTimeSync.png
Binary files differ