aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin2016-04-17 21:32:56 -0400
committerJustin2016-04-17 21:32:56 -0400
commita3cfc14442038b337560d4858e6b742c3c179769 (patch)
tree54e36a5441a70530ae6818f8d74500335d55b72f
downloadaur-a3cfc14442038b337560d4858e6b742c3c179769.tar.gz
Initialize repo
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore15
-rw-r--r--CHANGELOG.md13
-rw-r--r--PKGBUILD44
-rw-r--r--README.md18
-rw-r--r--freelancer-desktop-app.install7
6 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14744e656231
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = freelancer-desktop-app
+ pkgdesc = Freelancer.com desktop client
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://www.freelancer.com/desktop-app
+ install = freelancer-desktop-app.install
+ changelog = CHANGELOG.md
+ arch = i686
+ arch = x86_64
+ license = custom:freelancer
+ license = custom:oracle
+ source_i686 = http://desktop.freelancer.com/installers/freelancer-desktop-app_ubuntu-i386.deb
+ md5sums_i686 = d5f64ef74e3a1e2bf98714d647d3c22b
+ source_x86_64 = http://desktop.freelancer.com/installers/freelancer-desktop-app_ubuntu-amd64.deb
+ md5sums_x86_64 = d5f64ef74e3a1e2bf98714d647d3c22b
+
+pkgname = freelancer-desktop-app
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..902286aae05e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+*.deb
+*.rpm
+
+pkg/
+src/
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..6004f7df5a4d
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,13 @@
+# Changelog
+
+## [1.0.0](https://github.com/justintime4tea/aur-freelancer-desktop-app/tree/1.0.0)
+
+[Full Changelog](https://github.com/justintime4tea/aur-freelancer-desktop-app/compare/1.0.0...master)
+
+ - Add initial set of files
+ - Justin Gross <jgross.biz@gmail.com>
+ - [0c457b8](https://github.com/justintime4tea/aur-freelancer-desktop-app/commit/0c457b84adcf713ad3b4b3e19175d12fc565d1ad)
+
+- Initial commit
+ - Justin Gross <jgross.biz@gmail.com>
+ - [278ea6d](https://github.com/justintime4tea/aur-freelancer-desktop-app/commit/278ea6d20dde922432d2930281b280ed45c10c43) \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ba9bbd529c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Justin Gross <jgross.biz@gmail.com>
+
+pkgname=freelancer-desktop-app
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="Freelancer.com desktop client"
+arch=('i686' 'x86_64')
+url='https://www.freelancer.com/desktop-app'
+license=('custom:freelancer' 'custom:oracle')
+install="$pkgname.install"
+changelog=CHANGELOG.md
+source_i686=("http://desktop.freelancer.com/installers/${pkgname}_ubuntu-i386.deb")
+md5sums_i686=('d5f64ef74e3a1e2bf98714d647d3c22b')
+source_x86_64=("http://desktop.freelancer.com/installers/${pkgname}_ubuntu-amd64.deb")
+md5sums_x86_64=('d5f64ef74e3a1e2bf98714d647d3c22b')
+package() {
+ # Extract zipped tar files from Ubuntu deb package
+ tar -xzf control.tar.gz
+ tar -xzf data.tar.gz
+
+ # Prepare the opt directory
+ install -dm755 "$pkgdir/"{opt,usr/bin}
+
+ # Copy the directory containing the freelancer binary and application files
+ cp -R "$srcdir/opt/$pkgname" "$pkgdir/opt/$pkgname"
+
+ # Install the freelancer icon files to the appropriate locations
+ install -Dm644 "$srcdir/usr/share/applications/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/usr/share/pixmaps/hicolor/16x16/apps/$pkgname.png" "$pkgdir/usr/share/icons/hicolor/16x16/apps/$pkgname.png"
+ install -Dm644 "$srcdir/usr/share/pixmaps/hicolor/24x24/apps/$pkgname.png" "$pkgdir/usr/share/icons/hicolor/24x24/apps/$pkgname.png"
+ install -Dm644 "$srcdir/usr/share/pixmaps/hicolor/32x32/apps/$pkgname.png" "$pkgdir/usr/share/icons/hicolor/32x32/apps/$pkgname.png"
+ install -Dm644 "$srcdir/usr/share/pixmaps/hicolor/48x48/apps/$pkgname.png" "$pkgdir/usr/share/icons/hicolor/48x48/apps/$pkgname.png"
+ install -Dm644 "$srcdir/usr/share/pixmaps/hicolor/64x64/apps/$pkgname.png" "$pkgdir/usr/share/icons/hicolor/64x64/apps/$pkgname.png"
+ install -Dm644 "$srcdir/usr/share/pixmaps/hicolor/96x96/apps/$pkgname.png" "$pkgdir/usr/share/icons/hicolor/96x96/apps/$pkgname.png"
+ install -Dm644 "$srcdir/usr/share/pixmaps/hicolor/128x128/apps/$pkgname.png" "$pkgdir/usr/share/icons/hicolor/128x128/apps/$pkgname.png"
+ install -Dm644 "$srcdir/usr/share/pixmaps/hicolor/256x256/apps/$pkgname.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps/$pkgname.png"
+
+ # Create an execution script, without --skip-update Freelancer update process crashes with SHA1 sig invalid
+ echo "#!/bin/bash" >> "$pkgdir/usr/bin/$pkgname"
+ echo "/opt/$pkgname/$pkgname --skip-update" >> "$pkgdir/usr/bin/$pkgname"
+
+ # Make launch script executable
+ chmod 755 "$pkgdir/usr/bin/$pkgname"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..77ae125b4cf5
--- /dev/null
+++ b/README.md
@@ -0,0 +1,18 @@
+# aur-freelancer-desktop-app
+Arch Linux AUR Package for Freelancer.com desktop client.
+
+If you have installed an AUR helper like yaourt or pacaur then you should be able to install this package by running one of the following commands.
+
+For yaourt:
+
+yaourt -Syy freelancer-desktop-app
+
+For pacaur:
+
+pacaur -Syy freelancer-desktop-app
+
+If you have any issues please report them to the AUR or if you'd rather, report them here.
+
+If you wish to install this package manually run the following from your command line (not as root):
+
+ git clone https://github.com/justintime4tea/aur-freelancer-desktop-app.git && cd aur-freelancer-desktop-app && makepkg -sic \ No newline at end of file
diff --git a/freelancer-desktop-app.install b/freelancer-desktop-app.install
new file mode 100644
index 000000000000..8563b07e3e45
--- /dev/null
+++ b/freelancer-desktop-app.install
@@ -0,0 +1,7 @@
+pre_install() {
+ echo Installing Freelancer.com desktop client
+}
+
+post_install() {
+ echo Finished installing Freelancer.com desktop client
+}