summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlfredo Ramos2016-12-07 23:59:47 -0600
committerAlfredo Ramos2016-12-07 23:59:47 -0600
commit127b4518186bc895c93f04efc3a8529a6400fd3e (patch)
tree23c6080eef69eb9b21e48d035d5274452ba4c264
parent1c3d45aa4601f62248b08caf8a155e2a7432e208 (diff)
downloadaur-127b4518186bc895c93f04efc3a8529a6400fd3e.tar.gz
Fix compilation errors
- Update git submodule paths - Update enet patch
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
-rw-r--r--fix_enet_lib.patch (renamed from enet_shared_lib.patch)6
3 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81ffaf85fd08..02cee77e3229 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Jun 19 01:44:53 UTC 2016
pkgbase = freeminer-git
pkgdesc = An open source sandbox game inspired by Minecraft. Development version.
- pkgver = 0.4.13.7.1695.gaf93462
+ pkgver = 0.4.14.8.769.ge9e73d7
pkgrel = 2
url = http://freeminer.org/
arch = i686
@@ -26,16 +24,16 @@ pkgbase = freeminer-git
depends = libvorbis
depends = hicolor-icon-theme
depends = freetype2
- provides = freeminer=0.4.13.7.1695.gaf93462
+ provides = freeminer=0.4.14.8.769.ge9e73d7
conflicts = freeminer
source = git+https://github.com/freeminer/freeminer.git
source = git+https://github.com/freeminer/default.git
source = git+https://github.com/kaadmy/pixture.git
- source = enet_shared_lib.patch
+ source = fix_enet_lib.patch
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = ac51ee33df27f9fb3bdf16c50b2a9da602d6c55bba7afe21492d0056cdfefa5f84ccfb306c23bd2bcf22066ca3ef2a952110ba0de350602393754f0466383004
+ sha512sums = 8bdd0226cce1a8773feb840f90c392481d5486ef2bca5b144c1626df33a0bda861d93ccfb451eb5013aa42ab6fe2b029f44c02e9b85b32ed80a6668985deeb62
pkgname = freeminer-git
diff --git a/PKGBUILD b/PKGBUILD
index 83caec9c2d3d..34bb0ac02c53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=freeminer
pkgname=${_pkgname}-git
-pkgver=0.4.13.7.1695.gaf93462
+pkgver=0.4.14.8.769.ge9e73d7
pkgrel=2
pkgdesc='An open source sandbox game inspired by Minecraft. Development version.'
arch=('i686' 'x86_64')
@@ -23,36 +23,36 @@ source=(
"git+https://github.com/${_pkgname}/${_pkgname}.git"
"git+https://github.com/${_pkgname}/default.git"
"git+https://github.com/kaadmy/pixture.git"
- 'enet_shared_lib.patch'
+ 'fix_enet_lib.patch'
)
sha512sums=(
'SKIP'
'SKIP'
'SKIP'
- 'ac51ee33df27f9fb3bdf16c50b2a9da602d6c55bba7afe21492d0056cdfefa5f84ccfb306c23bd2bcf22066ca3ef2a952110ba0de350602393754f0466383004'
+ '8bdd0226cce1a8773feb840f90c392481d5486ef2bca5b144c1626df33a0bda861d93ccfb451eb5013aa42ab6fe2b029f44c02e9b85b32ed80a6668985deeb62'
)
pkgver() {
# Updating package version
cd "${srcdir}"/${_pkgname}
- git describe --long --tags | sed 's/-/./g'
+ git describe --long --tags 2>/dev/null | sed 's/-/./g'
}
prepare() {
cd "${srcdir}"/${_pkgname}
# Use Arch's enet lib
- patch -Np1 < ../enet_shared_lib.patch
+ patch -Np1 < ../fix_enet_lib.patch
- # Remove src/msgpack-c src/enet and src/jsoncpp submodules
- git submodule deinit src/{msgpack-c,enet,jsoncpp}
- git rm --cached src/{msgpack-c,enet,jsoncpp}
- git config -f .gitmodules --remove-section submodule.src/msgpack-c
- git config -f .gitmodules --remove-section submodule.src/enet
- git config -f .gitmodules --remove-section submodule.src/jsoncpp
+ # Remove msgpack-c, enet and jsoncpp submodules
+ git submodule deinit src/external/{msgpack-c,enet,jsoncpp}
+ git rm --cached src/external/{msgpack-c,enet,jsoncpp}
+ git config -f .gitmodules --remove-section submodule.src/external/msgpack-c
+ git config -f .gitmodules --remove-section submodule.src/external/enet
+ git config -f .gitmodules --remove-section submodule.src/external/jsoncpp
git add .gitmodules
- # Config submodules
+ # Configure submodules
git config submodule.games/default.url "${srcdir}"/default
git config submodule.games/pixture.url "${srcdir}"/pixture
git submodule update --init
diff --git a/enet_shared_lib.patch b/fix_enet_lib.patch
index da78e70b89ae..43e3890184b6 100644
--- a/enet_shared_lib.patch
+++ b/fix_enet_lib.patch
@@ -1,7 +1,7 @@
diff -uprNEBZ --suppress-blank-empty a/src/main.cpp b/src/main.cpp
---- a/src/main.cpp 2015-11-21 01:53:20.445038202 -0600
-+++ b/src/main.cpp 2015-11-21 01:57:13.407056516 -0600
-@@ -64,7 +64,7 @@ along with Freeminer. If not, see <http
+--- a/src/main.cpp 2016-12-07 18:10:06.000000000 -0600
++++ b/src/main.cpp 2016-12-07 23:39:37.707828396 -0600
+@@ -57,7 +57,7 @@ along with Freeminer. If not, see <http
#if USE_ENET
// todo: move to connection