summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2018-07-27 16:54:40 -0400
committerYour Name2018-07-27 16:54:40 -0400
commitd758e239eaaef703c753b851aab1e3bd357d7d22 (patch)
treeaaca2911edc821413add8e736c23e057c322bbf0
parent61e31bce2181269f317f1d87e52174829acc0696 (diff)
downloadaur-d758e239eaaef703c753b851aab1e3bd357d7d22.tar.gz
force utf8 encoding
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD2
3 files changed, 4 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aafc2cf415d0..233cb695d767 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Jul 21 04:35:59 UTC 2018
+# Fri Jul 27 20:54:37 UTC 2018
pkgbase = freenet
pkgdesc = An encrypted network without censorship
pkgver = 0.7.5.1481
diff --git a/.gitignore b/.gitignore
index 1a896b507342..0d0b420f293a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,6 +3,7 @@ fred/
plugin-*/
src/
pkg/
+.gradle/
*.jar
*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 3b5486a6b484..530a9c53dc05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -67,6 +67,7 @@ build() {
export JAVA_HOME="${JAVA_HOME:-/usr/lib/jvm/default}"
export GRADLE_USER_HOME="$srcdir"
+ export GRADLE_OPTS="-Dfile.encoding=UTF-8"
msg "Building Freenet..."
gradle copyRuntimeLibs
@@ -76,6 +77,7 @@ build() {
build_plugins() {
source /etc/profile.d/apache-ant.sh
+ export ANT_OPTS="-Dfile.encoding=UTF-8"
for plugin in ${_plugins[@]}; do
msg "Building Plugin ${plugin}..."