aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoratomlong2021-09-14 09:11:36 +0800
committeratomlong2021-09-14 09:29:40 +0800
commit20938ecbaf1c16c239d9e53e8dac2428dae5633e (patch)
treef4d3e8471a32881780f774d82d131f753ce578c2
parent88417a81d2f701d3fc767c547526c0f2ae8b54af (diff)
downloadaur-20938ecbaf1c16c239d9e53e8dac2428dae5633e.tar.gz
fix building on CI
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--destdir.patch28
3 files changed, 26 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5e0d61bbb9b..ffecda9241b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,6 @@ pkgbase = freenom-script
source = freenom-script::git+https://github.com/mkorthof/freenom-script.git
source = destdir.patch
md5sums = SKIP
- md5sums = 0ffe8df86934847971d6e2e04e211e60
+ md5sums = 4c4c7f8ee434fe6aad153c6eba8f391a
pkgname = freenom-script
diff --git a/PKGBUILD b/PKGBUILD
index acb3e23b9635..9c08fcea7bf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ depends=('curl')
source=("${pkgname}::git+${url}.git"
destdir.patch)
md5sums=('SKIP'
- '0ffe8df86934847971d6e2e04e211e60')
+ '4c4c7f8ee434fe6aad153c6eba8f391a')
install=freenom-script.install
pkgver() {
diff --git a/destdir.patch b/destdir.patch
index 050ba3e50e71..e0dc353aaf3d 100644
--- a/destdir.patch
+++ b/destdir.patch
@@ -1,7 +1,10 @@
-diff --git "a/Makefile" "b/Makefile"
-index 6c1dafc..ab77c51 100644
---- "a/Makefile"
-+++ "b/Makefile"
+ Makefile | 19 +++++++++++--------
+ 1 file changed, 11 insertions(+), 8 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 6c1dafc..79b19ed 100644
+--- a/Makefile
++++ b/Makefile
@@ -1,9 +1,9 @@
CONF = freenom.conf
SCRIPT = freenom.sh
@@ -16,6 +19,23 @@ index 6c1dafc..ab77c51 100644
ifneq ("$(shell grep ^staff: /etc/group)", "")
GROUP = staff
+@@ -11,14 +11,14 @@ else
+ GROUP = root
+ endif
+ EXISTCRON = 0
+-ifneq ("$(wildcard /run/systemd/system)", "")
++ifneq ("$(wildcard /usr/lib/systemd/system)", "")
+ SCHED = systemd
+ # ifneq ("$(wildcard /usr/lib/systemd/system)","")
+ # SYSDDIR = /lib/systemd/system
+ # else ifneq ("$(wildcard /lib/systemd/system)","")
+ # SYSDDIR = /usr/lib/systemd/system
+ # endif
+- LISTUNITS := $(shell systemctl list-unit-files --no-legend --no-page "freenom-*" 2>/dev/null|cut -d" " -f1)
++ LISTUNITS := $(shell ls $(SYSDDIR)/freenom-* 2>/dev/null)
+ else ifneq ("$(shell which cron 2>/dev/null)", "")
+ EXISTCRON = 1
+ SCHED = cron
@@ -50,12 +50,14 @@ ifeq ("$(wildcard $(SCRIPT))","")
$(error ERROR: Installation File "$(SCRIPT)" not found)
endif