summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEinhard Leichtfuß2024-02-18 14:29:53 +0100
committerEinhard Leichtfuß2024-02-18 14:29:53 +0100
commit298abf3552e8e6f22511494b81aad1724ebdc96f (patch)
tree5010856ca9cb841a53225646e4d0a547c1695969
parent52cd61917259adb941fd7c120b051df039e5eb0a (diff)
downloadaur-freesweep.tar.gz
Update to version 1.0.2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a466024de7bb..bee44b1894a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = freesweep
pkgdesc = a console minesweeper-style game written in C for *nix
- pkgver = 1.0.1
+ pkgver = 1.0.2
pkgrel = 1
- url = http://freecode.com/projects/freesweep
+ url = https://github.com/rwestlund/freesweep
install = freesweep.install
arch = x86_64
arch = i686
@@ -10,8 +10,7 @@ pkgbase = freesweep
depends = ncurses
backup = etc/sweeprc
backup = var/games/freesweep/sweeptimes
- source = https://github.com/rwestlund/freesweep/archive/v1.0.1.tar.gz
- sha512sums = 8270c77940225c8ebf0912ac896eaaaabd81775a82877650f3b9c2e0cf3b6a296b73f02ebc26e8fe526fc56f3807d9a2809f46e44b3d8507f011f9cf2c794099
+ source = freesweep-1.0.2.tar.gz::https://github.com/rwestlund/freesweep/archive/v1.0.2.tar.gz
+ sha512sums = 1695bb29efbaed5e6baf5faadcbd685e8e6b4ccb5d52567a833b5f5eeb69200fc220579fea7d6907bffc92a06e9b220bca494e8597394820a421f81f0af1d3aa
pkgname = freesweep
-
diff --git a/PKGBUILD b/PKGBUILD
index 6238106b7158..9728a2c9f874 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Einhard Leichtfuß <archer@respiranto.de>
pkgname=freesweep
-pkgver=1.0.1
+pkgver=1.0.2
pkgrel=1
pkgdesc="a console minesweeper-style game written in C for *nix"
arch=('x86_64' 'i686')
-url="http://freecode.com/projects/freesweep"
+url="https://github.com/rwestlund/freesweep"
license=('GPL')
depends=('ncurses')
backup=('etc/sweeprc' "var/games/$pkgname/sweeptimes")
install=$pkgname.install
-source=("https://github.com/rwestlund/freesweep/archive/v${pkgver}.tar.gz")
-sha512sums=('8270c77940225c8ebf0912ac896eaaaabd81775a82877650f3b9c2e0cf3b6a296b73f02ebc26e8fe526fc56f3807d9a2809f46e44b3d8507f011f9cf2c794099')
+source=("freesweep-${pkgver}.tar.gz::https://github.com/rwestlund/freesweep/archive/v${pkgver}.tar.gz")
+sha512sums=('1695bb29efbaed5e6baf5faadcbd685e8e6b4ccb5d52567a833b5f5eeb69200fc220579fea7d6907bffc92a06e9b220bca494e8597394820a421f81f0af1d3aa')
# Scores do not really work currently; They are saved,
# but for some reason not read / parsed correctly by the program,
@@ -30,6 +30,7 @@ prepare()
ln -sf /usr/share/libtool/build-aux/config.guess .
sed -i "s/0.8/$pkgver/" sweeprc
sed -i "s@mkstr(SCORESDIR)@\"$_scoresdir\"@" pbests.c
+ sed -Ei s/'^VERSION\s*=\s*1\.0\.1$'/"VERSION = ${pkgver}"/ Makefile.in
}
build()