summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2016-10-20 02:34:31 -0400
committerbrent s2016-10-20 02:34:31 -0400
commit30e6d24134b2b6c267274db8e15a2d262c91f9a8 (patch)
treeaa276ce1fc45478712e6ae7d7ec24df20dda90a7
parent8ee2d5c2e47fbc9a7425ded7dab1c3899f66cb3a (diff)
downloadaur-30e6d24134b2b6c267274db8e15a2d262c91f9a8.tar.gz
fixing some configure switches and the scripts
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD68
2 files changed, 48 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bd4329de89d..6a82ff50a78e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Oct 19 23:32:44 UTC 2016
+# Thu Oct 20 06:34:31 UTC 2016
pkgbase = freeswitch
pkgdesc = An opensource and free (libre, price) telephony system, similar to Asterisk.
pkgver = 1.6.10
- pkgrel = 2
+ pkgrel = 3
url = http://freeswitch.org/
install = freeswitch.install
changelog = ChangeLog
diff --git a/PKGBUILD b/PKGBUILD
index 050cd13eedb9..204bce0af1ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,7 +38,7 @@ _enabled_modules=(xml_int/mod_xml_curl
xml_int/mod_xml_cdr
formats/mod_shout
applications/mod_callcenter
- languages/mod_lua)
+ languages/mod_lua)
# DISABLED MODULES
# Remove from _disabled_modules if you want to build these
@@ -54,7 +54,7 @@ _disabled_modules=(languages/mod_spidermonkey
pkgname='freeswitch'
pkgver='1.6.10'
-pkgrel=2
+pkgrel=3
pkgdesc="An opensource and free (libre, price) telephony system, similar to Asterisk."
arch=('i686' 'x86_64')
url="http://freeswitch.org/"
@@ -68,10 +68,10 @@ depends=('curl'
'speex'
'libjpeg-turbo'
'postgresql-libs'
- 'libshout'
- 'lua'
- 'opus'
- 'freetype2')
+ 'libshout'
+ 'lua'
+ 'opus'
+ 'freetype2')
# per https://wiki.freeswitch.org/wiki/FreeSwitch_Dependencies, dependencies are downloaded and built *from upstream*, so thankfully the deps are pretty minimal.
makedepends=('git'
'libjpeg'
@@ -82,11 +82,11 @@ makedepends=('git'
'unixodbc'
'sed'
'make'
- 'libyuv-git'
- 'yasm'
- 'mpg123'
- 'lame'
- 'libsndfile')
+ 'libyuv-git'
+ 'yasm'
+ 'mpg123'
+ 'lame'
+ 'libsndfile')
# per https://aur.archlinux.org/packages/freeswitch-fixed/ 2014-08-13 14:02 comment, enable this when freetdm is packaged.
# freetdm will require libsangoma, wanpipe, libsng_isdn, libpri. see http://wiki.freeswitch.org/wiki/FreeTDM#Dependencies ; links below
# http://wiki.sangoma.com/wanpipe-linux-drivers
@@ -106,12 +106,12 @@ source=("git+https://stash.freeswitch.org/scm/fs/freeswitch.git#tag=v${pkgver}"
'run_log.freeswitch'
'conf_log.freeswitch'
'freeswitch.service'
- 'freeswitch.conf.d.sig'
- 'README.freeswitch.sig'
- 'run.freeswitch.sig'
- 'run_log.freeswitch.sig'
- 'conf_log.freeswitch.sig'
- 'freeswitch.service.sig')
+ 'freeswitch.conf.d.sig'
+ 'README.freeswitch.sig'
+ 'run.freeswitch.sig'
+ 'run_log.freeswitch.sig'
+ 'conf_log.freeswitch.sig'
+ 'freeswitch.service.sig')
changelog='ChangeLog'
_pkgname="freeswitch"
sha512sums=('SKIP'
@@ -164,16 +164,25 @@ build() {
sleep 5
# CONFIGURE
- ./configure --prefix=/var/lib/freeswitch --with-python=/usr/bin/python2 \
- --bindir=/usr/bin --sbindir=/usr/sbin --localstatedir=/var \
- --sysconfdir=/etc --datarootdir=/usr/share \
- --libexecdir=/usr/lib/freeswitch --libdir=/usr/lib/freeswitch \
- --includedir=/usr/include/freeswitch --enable-core-odbc-support \
+ ./configure \
+ --prefix=/var/lib/freeswitch \
+ --with-python=/usr/bin/python2 \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --localstatedir=/var \
+ --sysconfdir=/etc \
+ --datarootdir=/usr/share \
+ --libexecdir=/usr/lib/freeswitch \
+ --libdir=/usr/lib/freeswitch \
+ --includedir=/usr/include/freeswitch \
+ --enable-core-odbc-support \
--with-recordingsdir=/var/spool/freeswitch/recordings \
--with-dbdir=/var/spool/freeswitch/db \
--with-pkgconfigdir=/usr/lib/pkgconfig \
--with-logfiledir=/var/log/freeswitch \
--with-modinstdir=/usr/lib/freeswitch/mod \
+ --with-scriptdir=/usr/share/freeswitch/scripts \
+ --with-certsdir=/etc/freeswitch/certs \
--with-rundir=/run/freeswitch
# COMPILE
@@ -238,6 +247,7 @@ package() {
chmod 600 etc/freeswitch/private/passwords.xml
ln -sf /etc/freeswitch var/lib/freeswitch/conf
cp -a etc/freeswitch/* usr/share/doc/freeswitch/examples/conf.default/
+ install -d -m 0755 etc/freeswitch/certs
for _mod in ${_enabled_modules[@]};do
enable_mod_xml $_mod
@@ -254,4 +264,18 @@ package() {
install -D -m 0755 "${srcdir}/run_log.freeswitch" usr/share/freeswitch/log/run
install -D -m 0644 "${srcdir}/conf_log.freeswitch" usr/share/freeswitch/log/conf
+ # Fix scripts' path
+ cd ${pkgdir}/usr/share/freeswitch/scripts
+ rm -rf applescript
+ rm FreeSWITCH-debian-raspbian-installer.sh
+ for i in $(find ./ -type f);
+ do
+ sed -i -r \
+ -e 's@/usr/local/s?bin/@/usr/bin/@g' \
+ -e 's@/usr/local/freeswitch/certs@/etc/freeswitch/certs@g' \
+ -e 's@/usr/local/freeswitch/run/@/run/freeswitch@g' \
+ -e 's@/usr/local/freeswitch/log@/var/log@g' \
+ -e 's@/usr/local/freeswitch/bin@/usr/bin@g' \
+ -e 's@/usr/local/freeswitch/conf@/etc/freeswitch@g' "${i}"
+ done
}