summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2018-02-01 09:42:52 +0000
committerCharles Bos2018-02-01 09:42:52 +0000
commitf0d87f1652f8e8972f016eeb06d5a30565f3b7cd (patch)
tree8ac27320c03aeb338b85dddf280fd3e05c8abc98
parent936656beae3a728c1c59f5bca3bcd9a25fcd7711 (diff)
downloadaur-f0d87f1652f8e8972f016eeb06d5a30565f3b7cd.tar.gz
Add 2.9 regression patch as per the official package
-rw-r--r--.SRCINFO4
-rw-r--r--0001-psaux-Correctly-handle-Flex-features-52846.patch38
-rw-r--r--PKGBUILD8
3 files changed, 48 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2880410609f2..77f88f54b975 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = freetype2-ttmetrics
pkgdesc = Font rasterization library with TrueType metrics enabled
pkgver = 2.9
- pkgrel = 1
+ pkgrel = 2
url = https://www.freetype.org/
install = freetype2.install
arch = i686
@@ -21,6 +21,7 @@ pkgbase = freetype2-ttmetrics
source = 0001-Enable-table-validation-modules.patch
source = 0002-Enable-infinality-subpixel-hinting.patch
source = 0003-Enable-long-PCF-family-names.patch
+ source = 0001-psaux-Correctly-handle-Flex-features-52846.patch
source = freetype2.sh
source = enable_truetype_like_size_metrics.patch
source = revert_allow_linear_scaling.patch
@@ -28,6 +29,7 @@ pkgbase = freetype2-ttmetrics
sha1sums = b69531770c343d403be294b7e4d25ac45738c833
sha1sums = 3d26a569f0cb94c28a550577f5dcaadb4e193d91
sha1sums = 770f1981734a837bcf065564c91644b4cc5e256a
+ sha1sums = 21ad7dd31e16adb5b39adfa5671018a736626562
sha1sums = bc6df1661c4c33e20f5ce30c2da8ad3c2083665f
sha1sums = 833a8622bc61fc6f41c0e87c3614dec73490c9b1
sha1sums = f2cc372aedce56b387ee0c5403745d642bd44fe8
diff --git a/0001-psaux-Correctly-handle-Flex-features-52846.patch b/0001-psaux-Correctly-handle-Flex-features-52846.patch
new file mode 100644
index 000000000000..44630fbdcf1f
--- /dev/null
+++ b/0001-psaux-Correctly-handle-Flex-features-52846.patch
@@ -0,0 +1,38 @@
+From cc2f3cdecff5a351e7e8961b9f2e389ab740231a Mon Sep 17 00:00:00 2001
+From: Ewald Hew <ewaldhew@gmail.com>
+Date: Wed, 10 Jan 2018 13:24:56 +0800
+Subject: [PATCH] [psaux] Correctly handle Flex features (#52846).
+
+* src/psaux/psintrp.c (cf2_interpT2CharString) <cf2_cmdVMOVETO,
+cf2_cmdHMOVETO>: Do not move if doing Flex.
+---
+ src/psaux/psintrp.c | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/psaux/psintrp.c b/src/psaux/psintrp.c
+index 5c0ee78..da5a8da 100644
+--- a/src/psaux/psintrp.c
++++ b/src/psaux/psintrp.c
+@@ -852,7 +852,8 @@
+
+ curY = ADD_INT32( curY, cf2_stack_popFixed( opStack ) );
+
+- cf2_glyphpath_moveTo( &glyphPath, curX, curY );
++ if ( !decoder->flex_state )
++ cf2_glyphpath_moveTo( &glyphPath, curX, curY );
+
+ break;
+
+@@ -2674,7 +2675,8 @@
+
+ curX = ADD_INT32( curX, cf2_stack_popFixed( opStack ) );
+
+- cf2_glyphpath_moveTo( &glyphPath, curX, curY );
++ if ( !decoder->flex_state )
++ cf2_glyphpath_moveTo( &glyphPath, curX, curY );
+
+ break;
+
+--
+2.16.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 55d62e2f5163..561e170131df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=freetype2-ttmetrics
_srcname=freetype
pkgver=2.9
-pkgrel=1
+pkgrel=2
pkgdesc="Font rasterization library with TrueType metrics enabled"
arch=(i686 x86_64)
license=('GPL')
@@ -21,6 +21,7 @@ source=(https://download-mirror.savannah.gnu.org/releases/freetype/freetype-${pk
0001-Enable-table-validation-modules.patch
0002-Enable-infinality-subpixel-hinting.patch
0003-Enable-long-PCF-family-names.patch
+ 0001-psaux-Correctly-handle-Flex-features-52846.patch
freetype2.sh
enable_truetype_like_size_metrics.patch
revert_allow_linear_scaling.patch)
@@ -28,6 +29,7 @@ sha1sums=('94c4399b1a55c5892812e732843fcb4a7c2fe657'
'b69531770c343d403be294b7e4d25ac45738c833'
'3d26a569f0cb94c28a550577f5dcaadb4e193d91'
'770f1981734a837bcf065564c91644b4cc5e256a'
+ '21ad7dd31e16adb5b39adfa5671018a736626562'
'bc6df1661c4c33e20f5ce30c2da8ad3c2083665f'
'833a8622bc61fc6f41c0e87c3614dec73490c9b1'
'f2cc372aedce56b387ee0c5403745d642bd44fe8')
@@ -40,6 +42,10 @@ prepare() {
patch -Np1 -i ../0002-Enable-infinality-subpixel-hinting.patch
patch -Np1 -i ../0003-Enable-long-PCF-family-names.patch
+ # Freetype 2.9 regression: bad rendering for some Type 1 fonts
+ # https://savannah.nongnu.org/bugs/?52846
+ patch -Np1 -i ../0001-psaux-Correctly-handle-Flex-features-52846.patch
+
# ttmetrics patches
# see https://bbs.archlinux.org/viewtopic.php?id=226380
patch -Np1 -i ../enable_truetype_like_size_metrics.patch