summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaphaël Doursenaud2015-07-05 17:58:32 +0200
committerRaphaël Doursenaud2015-07-05 17:58:32 +0200
commit1411706127018dec43d232542e0319f961d15386 (patch)
treeadbe49112044042cd6472d34086a98f40962ccf3
downloadaur-1411706127018dec43d232542e0319f961d15386.tar.gz
Initial import
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD57
-rw-r--r--frescobaldi.install14
3 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d4b78907ccf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = frescobaldi
+ pkgdesc = A LilyPond sheet music text editor.
+ pkgver = 2.18.1
+ pkgrel = 2
+ url = http://www.frescobaldi.org/
+ install = frescobaldi.install
+ arch = any
+ license = GPL
+ depends = hyphen
+ depends = poppler
+ depends = python>=3.2
+ depends = python-ly>=0.9
+ depends = python-poppler-qt4
+ depends = python-pyqt4>=4.8.3
+ depends = qt4>=4.7
+ depends = tango-icon-theme
+ optdepends = lilypond: Music engraving (recommended)
+ optdepends = python-pygame-hg: MIDI playback (alternate engine)
+ optdepends = portmidi: MIDI playback (fallback engine)
+ optdepends = hyphen-de: German hyphenation rules
+ optdepends = hyphen-en: English hyphenation rules
+ optdepends = hyphen-es: Spanish hyphenation rules
+ optdepends = hyphen-fr: French hyphenation rules
+ optdepends = hyphen-hu: Hungarian hyphenation rules
+ optdepends = hyphen-it: Italian hyphenation rules
+ optdepends = hyphen-nl: Dutch hyphenation rules
+ optdepends = hyphen-ro: Romanian hyphenation rules
+ source = https://github.com/wbsoft/frescobaldi/releases/download/v2.18.1/frescobaldi-2.18.1.tar.gz
+ md5sums = 3cf2aae0d74717d5a7aff089fe46bc8c
+
+pkgname = frescobaldi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0b7a46d8488
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Contributor: David Virgilio <drvirgilio@gmail.com>
+# Contributor: David Zaragoza <david@zaragoza.com.ve>
+# Contributor: Clément Démoulins <clement@archivel.fr>
+# Maintainer: Raphaël Doursenaud <rdoursenaud@free.fr>
+
+pkgname=frescobaldi
+pkgver=2.18.1
+pkgrel=2
+pkgdesc="A LilyPond sheet music text editor."
+arch=('any')
+url="http://www.frescobaldi.org/"
+license=('GPL')
+depends=(
+ 'hyphen'
+ 'poppler'
+ 'python>=3.2'
+ 'python-ly>=0.9'
+ 'python-poppler-qt4'
+ 'python-pyqt4>=4.8.3'
+ 'qt4>=4.7'
+ 'tango-icon-theme'
+)
+optdepends=(
+ 'lilypond: Music engraving (recommended)'
+# python-portmidi is currently a python2 package
+# 'python-portmidi: MIDI playback (default engine)'
+ 'python-pygame-hg: MIDI playback (alternate engine)'
+ 'portmidi: MIDI playback (fallback engine)'
+ 'hyphen-de: German hyphenation rules'
+ 'hyphen-en: English hyphenation rules'
+ 'hyphen-es: Spanish hyphenation rules'
+ 'hyphen-fr: French hyphenation rules'
+ 'hyphen-hu: Hungarian hyphenation rules'
+ 'hyphen-it: Italian hyphenation rules'
+ 'hyphen-nl: Dutch hyphenation rules'
+ 'hyphen-ro: Romanian hyphenation rules'
+)
+source=(https://github.com/wbsoft/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
+install=$pkgname.install
+md5sums=('3cf2aae0d74717d5a7aff089fe46bc8c')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # Work around a bug in setuptools. Should be fixed soon.
+ sed -i '/win/ d' setup.cfg
+ # Provided by tango-icon-theme
+ rm -rf "frescobaldi_app/icons/Tango"
+ # Provided by hyphen-*
+ rm -rf "frescobaldi_app/hyphdicts"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/frescobaldi.install b/frescobaldi.install
new file mode 100644
index 000000000000..445c6c84c74a
--- /dev/null
+++ b/frescobaldi.install
@@ -0,0 +1,14 @@
+post_install() {
+ update-desktop-database -q
+ xdg-icon-resource forceupdate
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: