summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2017-09-04 11:03:02 +0100
committerWorMzy Tykashi2017-09-04 11:03:02 +0100
commit284fbefa446e351d0d9a02eb0b9d5721de80763d (patch)
tree7759f5e0084dc3c0336568eccd405c7bdd830360
parent02ce077666f288d2f0a3910563140bb3b74be29d (diff)
downloadaur-284fbefa446e351d0d9a02eb0b9d5721de80763d.tar.gz
Fixed PKGBUILD, updated to 0.3.7
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD36
2 files changed, 33 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a491f226ce7d..e5b0a69b5e0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,38 @@
-# Generated by mksrcinfo v8
-# Thu Oct 6 14:46:13 UTC 2016
pkgbase = freshplayerplugin
pkgdesc = PPAPI-host NPAPI-plugin adapter.
- pkgver = 0.3.6
+ pkgver = 0.3.7
pkgrel = 1
url = https://github.com/i-rinat/freshplayerplugin
install = freshplayerplugin.install
arch = i686
arch = x86_64
license = MIT
+ makedepends = libdrm
makedepends = cmake
makedepends = ragel
- depends = pango
depends = alsa-lib
+ depends = cairo
+ depends = ffmpeg
depends = freetype2
+ depends = glib2
+ depends = icu
+ depends = jack
depends = libevent
- depends = gtk3
depends = libgl
+ depends = libsoxr
+ depends = libva
+ depends = libvdpau
+ depends = libx11
+ depends = libxcursor
+ depends = libxrandr
+ depends = libxrender
+ depends = openssl
+ depends = pango
depends = v4l-utils
- depends = ffmpeg
- depends = icu
optdepends = pepper-flash: for the necessary Pepper plugin
- conflicts = freshplayerplugin-git
- source = https://github.com/i-rinat/freshplayerplugin/archive/v0.3.6.tar.gz
+ source = https://github.com/i-rinat/freshplayerplugin/archive/v0.3.7.tar.gz
source = freshplayerplugin.install
- sha1sums = 255dc4ad0dbad26ed92e1b7dbdd615e75096b05f
+ sha1sums = e7f9bf791a3d70e386eb98f3e7c6478a891bff29
sha1sums = 331a3b3877249eaf1c3db917bde1dea6c4d374ab
pkgname = freshplayerplugin
diff --git a/PKGBUILD b/PKGBUILD
index acaae96f8a49..ce509dd6ae84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Maintainer: Jack L. Frost <fbt@fleshless.org>
-# vim: expandtab sts=2
+# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
+# Contributor: Jack L. Frost <fbt@fleshless.org>
# Contributor: Corelli <corelli AT sent DOT com>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: intelfx <intelfx100 [at] gmail [dot] com>
@@ -7,41 +7,35 @@
# Contributor: zman0900 <zman0900@gmail.com>
pkgname=freshplayerplugin
-pkgver=0.3.6
+pkgver=0.3.7
pkgrel=1
pkgdesc='PPAPI-host NPAPI-plugin adapter.'
-arch=( 'i686' 'x86_64' )
+arch=('i686' 'x86_64')
url='https://github.com/i-rinat/freshplayerplugin'
-license=( 'MIT' )
-depends=( 'pango' 'alsa-lib' 'freetype2' 'libevent' 'gtk3' 'libgl' 'v4l-utils' 'ffmpeg' 'icu' )
-makedepends=( 'cmake' 'ragel' )
-conflicts=( 'freshplayerplugin-git' )
+license=('MIT')
+depends=('alsa-lib' 'cairo' 'ffmpeg' 'freetype2' 'glib2' 'icu' 'jack'
+ 'libevent' 'libgl' 'libsoxr' 'libva' 'libvdpau' 'libx11'
+ 'libxcursor' 'libxrandr' 'libxrender' 'openssl' 'pango' 'v4l-utils')
+makedepends=('libdrm' 'cmake' 'ragel')
+optdepends=('pepper-flash: for the necessary Pepper plugin')
install="${pkgname}.install"
-
-source=(
- "${url}/archive/v${pkgver}.tar.gz"
- "${pkgname}.install"
-)
-
-optdepends=(
- 'pepper-flash: for the necessary Pepper plugin'
-)
+source=("${url}/archive/v${pkgver}.tar.gz"
+ "${pkgname}.install")
+sha1sums=('e7f9bf791a3d70e386eb98f3e7c6478a891bff29'
+ '331a3b3877249eaf1c3db917bde1dea6c4d374ab')
build() {
cd "${pkgname}-${pkgver}"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DWITH_GTK=3
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
cd "${pkgname}-${pkgver}"
-
make DESTDIR="${pkgdir}" install
install -Dm644 data/freshwrapper.conf.example "${pkgdir}/usr/share/${pkgname}/freshwrapper.conf.example"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-sha1sums=('255dc4ad0dbad26ed92e1b7dbdd615e75096b05f'
- '331a3b3877249eaf1c3db917bde1dea6c4d374ab')