summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfbt2015-06-08 12:14:26 +0300
committerfbt2015-06-08 12:14:26 +0300
commit97684dd99bc2901f343857fa9de100bdaf4261a1 (patch)
tree5a2aadd2778909b259caed408363411407f5295c
downloadaur-97684dd99bc2901f343857fa9de100bdaf4261a1.tar.gz
init
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD35
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ad4ce92d92f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = freshplayerplugin
+ pkgdesc = PPAPI-host NPAPI-plugin adapter.
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = https://github.com/i-rinat/freshplayerplugin
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = ragel
+ depends = pango
+ depends = alsa-lib
+ depends = freetype2
+ depends = libconfig
+ depends = libevent
+ depends = gtk2
+ depends = libgl
+ depends = pepper-flash
+ conflicts = freshplayerplugin-git
+ source = https://github.com/i-rinat/freshplayerplugin/archive/v0.2.4.tar.gz
+ sha1sums = 360fc6f76f325079c5054e633947d948ed8ef9fc
+
+pkgname = freshplayerplugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb7413f2184a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jack L. Frost <fbt@fleshless.org>
+# vim: expandtab sts=2
+# Contributor: Corelli <corelli AT sent DOT com>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: intelfx <intelfx100 [at] gmail [dot] com>
+# Contributor: Behem0th <grantipak@gmail.com>
+
+pkgname=freshplayerplugin
+pkgver=0.2.4
+pkgrel=1
+pkgdesc='PPAPI-host NPAPI-plugin adapter.'
+arch=( 'i686' 'x86_64' )
+url='https://github.com/i-rinat/freshplayerplugin'
+license=( 'MIT' )
+depends=( 'pango' 'alsa-lib' 'freetype2' 'libconfig' 'libevent' 'gtk2' 'libgl' 'pepper-flash' )
+makedepends=( 'cmake' 'ragel' )
+conflicts=( 'freshplayerplugin-git' )
+
+source=( "$url/archive/v$pkgver.tar.gz" )
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -d "${pkgdir}/usr/lib/mozilla/plugins"
+ install -m644 libfreshwrapper-*.so "${pkgdir}/usr/lib/mozilla/plugins"
+ install -Dm644 data/freshwrapper.conf.example "${pkgdir}/usr/share/${pkgname}/freshwrapper.conf.example"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+sha1sums=('360fc6f76f325079c5054e633947d948ed8ef9fc')