summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfbt2015-06-12 18:27:25 +0300
committerfbt2015-06-12 18:27:25 +0300
commitc41186c478d1007e7cfdd81e6710a04b591d60d0 (patch)
tree4bd1201ef716675e5c91a40d3e3d0a492a66c97b
parent97684dd99bc2901f343857fa9de100bdaf4261a1 (diff)
downloadaur-c41186c478d1007e7cfdd81e6710a04b591d60d0.tar.gz
0.3.0
-rw-r--r--PKGBUILD23
-rw-r--r--freshplayerplugin.install7
2 files changed, 25 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb7413f2184a..cdbafc47c4b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,17 +6,29 @@
# Contributor: Behem0th <grantipak@gmail.com>
pkgname=freshplayerplugin
-pkgver=0.2.4
-pkgrel=1
+pkgver=0.3.0
+pkgrel=2
pkgdesc='PPAPI-host NPAPI-plugin adapter.'
arch=( 'i686' 'x86_64' )
url='https://github.com/i-rinat/freshplayerplugin'
license=( 'MIT' )
-depends=( 'pango' 'alsa-lib' 'freetype2' 'libconfig' 'libevent' 'gtk2' 'libgl' 'pepper-flash' )
+depends=( 'pango' 'alsa-lib' 'freetype2' 'libconfig' 'libevent' 'gtk2' 'libgl' 'v4l-utils' 'ffmpeg' )
makedepends=( 'cmake' 'ragel' )
conflicts=( 'freshplayerplugin-git' )
+install="${pkgname}.install"
-source=( "$url/archive/v$pkgver.tar.gz" )
+source=(
+ "${url}/archive/v${pkgver}.tar.gz"
+ "${pkgname}.install"
+)
+
+optdepends=(
+ 'chromium-pepper-flash: for the necessary Pepper plugin'
+ 'chromium-pepper-flash-standalone: for the necessary Pepper plugin'
+ 'google-chrome: for the necessary Pepper plugin'
+ 'google-chrome-beta: for the necessary Pepper plugin'
+ 'google-chrome-dev: for the necessary Pepper plugin'
+)
build() {
cd "${pkgname}-${pkgver}"
@@ -32,4 +44,5 @@ package() {
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-sha1sums=('360fc6f76f325079c5054e633947d948ed8ef9fc')
+sha1sums=('e0a5897942c26e05294f42a894347768bccb1b41'
+ '331a3b3877249eaf1c3db917bde1dea6c4d374ab')
diff --git a/freshplayerplugin.install b/freshplayerplugin.install
new file mode 100644
index 000000000000..9d52af027457
--- /dev/null
+++ b/freshplayerplugin.install
@@ -0,0 +1,7 @@
+post_install() {
+ while read; do printf '%s\n' "$REPLY"; done <<- EOF
+ Warning! This package requires the pepper flash plugin
+ that is available in one of the packages in the optdepends
+ array! It will not work without one of those!
+ EOF
+}