summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfbt2016-03-11 11:16:52 +0300
committerfbt2016-03-11 11:16:52 +0300
commitd8fce8e0cdbf35dd6700eb71fef284aa8bf274b7 (patch)
tree90d828253dbe9449b6b234485572cfe4d532d0ff
parent5c1dd7991814f9f6f17f610c7d6557c7f80bb74c (diff)
downloadaur-d8fce8e0cdbf35dd6700eb71fef284aa8bf274b7.tar.gz
Some fixes; new contributor
Signed-off-by: fbt <fbt@fleshless.org>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f2631e9c950..a505a27abc1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Dec 28 18:31:13 UTC 2015
+# Fri Mar 11 08:14:11 UTC 2016
pkgbase = freshplayerplugin
pkgdesc = PPAPI-host NPAPI-plugin adapter.
pkgver = 0.3.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/i-rinat/freshplayerplugin
install = freshplayerplugin.install
arch = i686
@@ -15,7 +15,7 @@ pkgbase = freshplayerplugin
depends = alsa-lib
depends = freetype2
depends = libevent
- depends = gtk2
+ depends = gtk3
depends = libgl
depends = v4l-utils
depends = ffmpeg
diff --git a/PKGBUILD b/PKGBUILD
index 62629c8bb323..f4f51ea95fe1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,16 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: intelfx <intelfx100 [at] gmail [dot] com>
# Contributor: Behem0th <grantipak@gmail.com>
+# Contributor: zman0900 <zman0900@gmail.com>
pkgname=freshplayerplugin
pkgver=0.3.4
-pkgrel=1
+pkgrel=2
pkgdesc='PPAPI-host NPAPI-plugin adapter.'
arch=( 'i686' 'x86_64' )
url='https://github.com/i-rinat/freshplayerplugin'
license=( 'MIT' )
-depends=( 'pango' 'alsa-lib' 'freetype2' 'libevent' 'gtk2' 'libgl' 'v4l-utils' 'ffmpeg' )
+depends=( 'pango' 'alsa-lib' 'freetype2' 'libevent' 'gtk3' 'libgl' 'v4l-utils' 'ffmpeg' )
makedepends=( 'cmake' 'ragel' )
conflicts=( 'freshplayerplugin-git' )
install="${pkgname}.install"
@@ -32,14 +33,16 @@ optdepends=(
build() {
cd "${pkgname}-${pkgver}"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
+
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DWITH_GTK=3
make
}
package() {
cd "${pkgname}-${pkgver}"
- install -d "${pkgdir}/usr/lib/mozilla/plugins"
- install -m644 libfreshwrapper-*.so "${pkgdir}/usr/lib/mozilla/plugins"
+
+ make DESTDIR="${pkgdir}" install
+
install -Dm644 data/freshwrapper.conf.example "${pkgdir}/usr/share/${pkgname}/freshwrapper.conf.example"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}