summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfbt2015-06-30 12:19:40 +0300
committerfbt2015-06-30 12:19:40 +0300
commitb48375217e4403047b65872b2a467106850b901d (patch)
tree40149fdbe0eed0c4de8a35f5d998a65886f0027b
downloadaur-b48375217e4403047b65872b2a467106850b901d.tar.gz
init
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD55
-rw-r--r--freshplayerplugin-git.install7
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f398f56ed2c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = freshplayerplugin-git
+ pkgdesc = PPAPI-host NPAPI-plugin adapter.
+ pkgver = v0.2.4.r92.g96ba6ad
+ pkgrel = 1
+ url = https://github.com/i-rinat/freshplayerplugin
+ install = freshplayerplugin-git.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = ragel
+ makedepends = git
+ depends = pango
+ depends = alsa-lib
+ depends = freetype2
+ depends = libconfig
+ depends = libevent
+ depends = gtk2
+ depends = libgl
+ depends = v4l-utils
+ optdepends = chromium-pepper-flash: for the necessary Pepper plugin
+ optdepends = chromium-pepper-flash-standalone: for the necessary Pepper plugin
+ optdepends = google-chrome: for the necessary Pepper plugin
+ optdepends = google-chrome-beta: for the necessary Pepper plugin
+ optdepends = google-chrome-dev: for the necessary Pepper plugin
+ conflicts = freshplayerplugin
+ source = freshplayerplugin-git::git+https://github.com/i-rinat/freshplayerplugin
+ source = freshplayerplugin-git.install
+ sha1sums = SKIP
+ sha1sums = 331a3b3877249eaf1c3db917bde1dea6c4d374ab
+
+pkgname = freshplayerplugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..384a7537e876
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Jack L. Frost <fbt@fleshless.org>
+# vim: expandtab sts=2
+# Contributor: Corelli <corelli AT sent DOT com>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: intelfx <intelfx100 [at] gmail [dot] com>
+# Contributor: Behem0th <grantipak@gmail.com>
+
+pkgname=freshplayerplugin-git
+pkgver=v0.2.4.r92.g96ba6ad
+pkgrel=1
+pkgdesc='PPAPI-host NPAPI-plugin adapter.'
+arch=( 'i686' 'x86_64' )
+url='https://github.com/i-rinat/freshplayerplugin'
+license=( 'MIT' )
+depends=( 'pango' 'alsa-lib' 'freetype2' 'libconfig' 'libevent' 'gtk2' 'libgl' 'v4l-utils' )
+makedepends=( 'cmake' 'ragel' 'git' )
+conflicts=( 'freshplayerplugin' )
+source=( "${pkgname}::git+${url}" "${pkgname}.install" )
+install="${pkgname}.install"
+
+optdepends=(
+ 'chromium-pepper-flash: for the necessary Pepper plugin'
+ 'chromium-pepper-flash-standalone: for the necessary Pepper plugin'
+ 'google-chrome: for the necessary Pepper plugin'
+ 'google-chrome-beta: for the necessary Pepper plugin'
+ 'google-chrome-dev: for the necessary Pepper plugin'
+)
+
+pkgver() {
+ cd "$pkgname"
+
+ if git_version=$( git describe --long --tags 2>/dev/null ); then
+ IFS='-' read last_tag tag_rev commit <<< "$git_version"
+ printf '%s.r%s.%s' "$last_tag" "$tag_rev" "$commit"
+ else
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ fi
+}
+
+build() {
+ cd "$pkgname"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$pkgname"
+ install -d "${pkgdir}/usr/lib/mozilla/plugins"
+ install -m644 libfreshwrapper-*.so "${pkgdir}/usr/lib/mozilla/plugins"
+ install -Dm644 data/freshwrapper.conf.example "${pkgdir}/usr/share/${pkgname}/freshwrapper.conf.example"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+sha1sums=('SKIP'
+ '331a3b3877249eaf1c3db917bde1dea6c4d374ab')
diff --git a/freshplayerplugin-git.install b/freshplayerplugin-git.install
new file mode 100644
index 000000000000..9d52af027457
--- /dev/null
+++ b/freshplayerplugin-git.install
@@ -0,0 +1,7 @@
+post_install() {
+ while read; do printf '%s\n' "$REPLY"; done <<- EOF
+ Warning! This package requires the pepper flash plugin
+ that is available in one of the packages in the optdepends
+ array! It will not work without one of those!
+ EOF
+}