summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubuWest2020-06-04 22:04:03 +0200
committerLubuWest2020-06-04 22:04:03 +0200
commitc827464b11d563147b7d6d26ee56ae9eb391d51f (patch)
treeafcb65b7b33bcc00f4b22d99dda9d186d1d426fc
downloadaur-c827464b11d563147b7d6d26ee56ae9eb391d51f.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf9439d51e85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = friendiqa
+ pkgdesc = Client for social network Friendica
+ pkgver = 0.5.3
+ pkgrel = 1
+ url = https://git.friendi.ca/lubuwest/Friendiqa
+ arch = any
+ license = GPL3
+ depends = qt5-base
+ depends = qt5-declarative
+ depends = qt5-multimedia
+ depends = qt5-quickcontrols2
+ depends = qt5-webengine
+ depends = qt5-webview
+ source = friendiqa-0.5.3.tar.gz::https://git.friendi.ca/lubuwest/Friendiqa/archive/v0.5.3.tar.gz
+ md5sums = 5a90b6cdf0d782f6337bc2ad321ecb0b
+
+pkgname = friendiqa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e012b178bbe1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# See http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
+# for more information on packaging from GIT sources.
+
+# Maintainer: Marco R. <thomasschmidt45@gmx.net>
+pkgname=friendiqa
+pkgver=0.5.3
+pkgrel=1
+pkgdesc="Client for social network Friendica"
+arch=('any')
+url="https://git.friendi.ca/lubuwest/Friendiqa"
+license=('GPL3')
+depends=('qt5-base' 'qt5-declarative' 'qt5-multimedia' 'qt5-quickcontrols2' 'qt5-webengine' 'qt5-webview' )
+source=("$pkgname-$pkgver.tar.gz::https://git.friendi.ca/lubuwest/Friendiqa/archive/v${pkgver}.tar.gz")
+md5sums=('5a90b6cdf0d782f6337bc2ad321ecb0b') #generate with 'makepkg -g'
+
+build() {
+ cd "$pkgname/source-linux"
+ qmake
+ make
+}
+
+package() {
+ cd "$pkgname/source-linux"
+ make INSTALL_ROOT="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: