summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexis Williams2024-03-09 19:32:14 -0800
committerAlexis Williams2024-03-09 19:32:14 -0800
commit72bdc5f23e0f631ab1cb488620635d4e7d202fbf (patch)
treec129d815fbdbd2d5e202afe4578b35668f61bd88
parentd74d0771dd7bf399bbd6f880be4d9519c7e5f6ba (diff)
downloadaur-72bdc5f23e0f631ab1cb488620635d4e7d202fbf.tar.gz
Fix incorrect passage of Java options
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd6fe1f4eafd..9b81f7ea723d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexis Williams <alexis@typedr.at>
pkgname=frink-lang-bin
pkgver=20240227
-pkgrel=1
+pkgrel=2
pkgdesc="A practical calculating tool and programming language."
arch=('any')
url="https://frinklang.org/"
@@ -59,8 +59,7 @@ java_opts=(
"-Dswing.crossplatformlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel"
)
-export _JAVA_OPTIONS="${java_opts[*]}"
-exec $rlwrap $rlwrap_args /usr/bin/java -cp $CP frink.gui.FrinkStarter "$@"
+exec $rlwrap $rlwrap_args /usr/bin/java ${java_opts[*]} -cp $CP frink.gui.FrinkStarter "$@"
EOF
chmod a+x "$pkgdir/usr/bin/frink"