summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2020-12-26 23:15:08 +0100
committerGianluca Boiano2020-12-26 23:15:08 +0100
commitd76bb9d8279fea7654159cd54e1c9ab2987dc2fd (patch)
tree7d19961cd50dbfb9d30658bd1a0638f9fcdb493b
parent578ae11be843a84946b3322b9d998107aa5e94bc (diff)
downloadaur-d76bb9d8279fea7654159cd54e1c9ab2987dc2fd.tar.gz
friture: 0.42
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
2 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0864db324eaa..f17e0745e5a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = friture
pkgdesc = An application to visualize and analyze live audio data in real-time.
- pkgver = 0.41
- pkgrel = 2
+ pkgver = 0.42
+ pkgrel = 1
url = http://tlecomte.github.com/friture/
arch = i686
arch = x86_64
@@ -19,10 +19,8 @@ pkgbase = friture
depends = python-rtmixer
depends = python-sounddevice
optdepends = jack: for JACK I/O support
- source = https://github.com/tlecomte/friture/archive/v0.41.tar.gz
- source = numpy.patch
- sha256sums = f778798392ff29284c2cdbc3563ec83552b8a8a464a5ad35e5678448cc335a7c
- sha256sums = f9cb7120a6ee8ef23706c0c83930714ed81aced0ff2915924833fafdc646585d
+ source = https://github.com/tlecomte/friture/archive/99dd16498888a5fc5f14bb00c380cb5ce2f54c73.tar.gz
+ sha256sums = 1a2fc0e6a728c3444a712fc69f14248bae3ebdb526c879bbdb26a2798f1906ae
pkgname = friture
diff --git a/PKGBUILD b/PKGBUILD
index f43417994c3a..81b3e005615b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: speps <speps at aur dot archlinux dot org>
pkgname=friture
-pkgver=0.41
-pkgrel=2
+pkgver=0.42
+pkgrel=1
pkgdesc="An application to visualize and analyze live audio data in real-time."
arch=(i686 x86_64)
url="http://tlecomte.github.com/friture/"
@@ -12,22 +12,20 @@ license=('GPL3')
depends=('python-appdirs' 'python-docutils' 'python-multipledispatch' 'python-numpy' 'python-opengl' 'python-pa-ringbuffer' 'python-pyqt5' 'python-pyrr' 'python-rtmixer' 'python-sounddevice')
optdepends=('jack: for JACK I/O support')
makedepends=('cython' 'python-wheel')
-source=("https://github.com/tlecomte/$pkgname/archive/v$pkgver.tar.gz"
- numpy.patch)
+_commit=99dd16498888a5fc5f14bb00c380cb5ce2f54c73
+source=("https://github.com/tlecomte/$pkgname/archive/${_commit}.tar.gz")
build() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -Np1 -i ../numpy.patch
- python setup.py build
+ cd "$srcdir/$pkgname-${_commit}"
+ python setup.py build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/"
- install -Dm644 resources/images/friture.iconset/icon_512x512.png $pkgdir/usr/share/pixmaps/${pkgname}.png
- install -Dm644 appimage/$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
- sed -i "s|usr|/usr|g" "$pkgdir"/usr/share/applications/$pkgname.desktop
+ cd "$srcdir/$pkgname-${_commit}"
+ python setup.py install --root="$pkgdir/"
+ install -Dm644 resources/images/friture.iconset/icon_512x512.png $pkgdir/usr/share/pixmaps/${pkgname}.png
+ install -Dm644 appimage/$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ sed -i "s|usr|/usr|g" "$pkgdir"/usr/share/applications/$pkgname.desktop
}
-sha256sums=('f778798392ff29284c2cdbc3563ec83552b8a8a464a5ad35e5678448cc335a7c'
- 'f9cb7120a6ee8ef23706c0c83930714ed81aced0ff2915924833fafdc646585d')
+sha256sums=('1a2fc0e6a728c3444a712fc69f14248bae3ebdb526c879bbdb26a2798f1906ae')