summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302022-09-16 09:35:58 +0200
committerM0Rf302022-09-16 09:35:58 +0200
commit6c932ccc903e884e2abfe7e670511ac863ac2b80 (patch)
tree1b46392338bc6b95124d24f25e4869791e2da0df
parent33cd35c192c7e392d0f5b01f8cb5457987ea098d (diff)
downloadaur-6c932ccc903e884e2abfe7e670511ac863ac2b80.tar.gz
friture-git: add missing makedeps
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD37
2 files changed, 26 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7b23964c88f..df57d3683caf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = friture-git
pkgdesc = An application to visualize and analyze live audio data in real-time.
- pkgver = v0.41.r32.g91acd22
+ pkgver = v0.49.r1.ge12cd9a
pkgrel = 1
- url = http://tlecomte.github.com/friture/
+ url = https://friture.org/
arch = i686
arch = x86_64
license = GPL3
makedepends = cython
makedepends = git
+ makedepends = python-pip
+ makedepends = python-setuptools
makedepends = python-wheel
depends = python-appdirs
depends = python-docutils
depends = python-multipledispatch
depends = python-numpy
- depends = python-opengl
depends = python-pa-ringbuffer
depends = python-pyqt5
depends = python-pyrr
@@ -21,8 +22,8 @@ pkgbase = friture-git
depends = python-sounddevice
optdepends = jack: for JACK I/O support
conflicts = friture
+ replaces = friture
source = friture::git+https://github.com/tlecomte/friture.git
md5sums = SKIP
pkgname = friture-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 78dbafeff529..b99389724a7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,40 @@
# Maintainer: robertfoster
pkgname=friture-git
-pkgver=v0.41.r32.g91acd22
+pkgver=v0.49.r1.ge12cd9a
pkgrel=1
pkgdesc="An application to visualize and analyze live audio data in real-time."
arch=(i686 x86_64)
-url="http://tlecomte.github.com/friture/"
+url="https://friture.org/"
license=('GPL3')
-depends=('python-appdirs' 'python-docutils' 'python-multipledispatch' 'python-numpy' 'python-opengl' 'python-pa-ringbuffer' 'python-pyqt5' 'python-pyrr' 'python-rtmixer' 'python-sounddevice')
+depends=('python-appdirs' 'python-docutils' 'python-multipledispatch' 'python-numpy' 'python-pa-ringbuffer' 'python-pyqt5' 'python-pyrr' 'python-rtmixer' 'python-sounddevice')
optdepends=('jack: for JACK I/O support')
-makedepends=('cython' 'git' 'python-wheel')
-conflicts=('friture')
-source=("friture::git+https://github.com/tlecomte/friture.git")
+makedepends=('cython' 'git' 'python-pip' 'python-setuptools' 'python-wheel')
+conflicts=("${pkgname%-git}")
+replaces=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://github.com/tlecomte/friture.git")
build() {
- cd friture
- python setup.py build
+ cd ${pkgname%-git}
+ python setup.py build
}
package() {
- cd friture
- python setup.py install --root="$pkgdir/"
- install -Dm644 resources/images/friture.iconset/icon_512x512.png $pkgdir/usr/share/pixmaps/${pkgname%%-git}.png
- install -Dm644 appimage/${pkgname%%-git}.desktop "$pkgdir"/usr/share/applications/${pkgname%%-git}.desktop
- sed -i "s|usr|/usr|g" "$pkgdir"/usr/share/applications/${pkgname%%-git}.desktop
-
+ cd ${pkgname%-git}
+
+ python setup.py install --root="${pkgdir}/"
+
+ install -Dm644 resources/images/friture.iconset/icon_512x512.png \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "appimage/${pkgname%-git}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname%-git}.desktop"
+ sed -i "s|usr|/usr|g" \
+ "${pkgdir}/usr/share/applications/${pkgname%-git}.desktop"
}
pkgver() {
- cd friture
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd friture
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
md5sums=('SKIP')