summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302019-09-08 18:36:07 +0200
committerM0Rf302019-09-08 18:36:07 +0200
commit86600bcd347450a96878ba763814209a7e2bc0bd (patch)
treeb94c5a74a49419d1b2d2a25199132d9fc777e6ab
parentadf002eba39ac2fe5430b20db0fa1a2da5975c4f (diff)
downloadaur-86600bcd347450a96878ba763814209a7e2bc0bd.tar.gz
friture-git: 0.38
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
-rw-r--r--friture.desktop10
3 files changed, 14 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e196becf9d2b..acb8acfe167b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = friture-git
pkgdesc = An application to visualize and analyze live audio data in real-time.
- pkgver = v0.35.r2.g66231f3
+ pkgver = v0.38.pre.r1.g6042801
pkgrel = 1
url = http://tlecomte.github.com/friture/
arch = i686
@@ -8,19 +8,17 @@ pkgbase = friture-git
license = GPL3
makedepends = cython
makedepends = git
- depends = pyqwt
+ depends = python-appdirs
+ depends = python-docutils
+ depends = python-numpy
depends = python-opengl
- depends = python-psutil
- depends = python-pyaudio
depends = python-pyqt5
depends = python-pyrr
- depends = python-scipy
depends = python-sounddevice
optdepends = jack: for JACK I/O support
+ conflicts = friture
source = friture::git+https://github.com/tlecomte/friture.git
- source = friture.desktop
md5sums = SKIP
- md5sums = 90243c7bedd2dfca1429498561ce796b
pkgname = friture-git
diff --git a/PKGBUILD b/PKGBUILD
index b03edafdf4ac..a729363194ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: robertfoster
pkgname=friture-git
-pkgver=v0.35.r2.g66231f3
+pkgver=v0.38.pre.r1.g6042801
pkgrel=1
pkgdesc="An application to visualize and analyze live audio data in real-time."
arch=(i686 x86_64)
url="http://tlecomte.github.com/friture/"
license=('GPL3')
-depends=('pyqwt' 'python-opengl' 'python-psutil' 'python-pyaudio' 'python-pyqt5' 'python-pyrr' 'python-scipy' 'python-sounddevice')
+depends=('python-appdirs' 'python-docutils' 'python-numpy' 'python-opengl' 'python-pyqt5' 'python-pyrr' 'python-sounddevice')
optdepends=('jack: for JACK I/O support')
makedepends=('cython' 'git')
-source=("friture::git+https://github.com/tlecomte/friture.git"
-friture.desktop)
+conflicts=('friture')
+source=("friture::git+https://github.com/tlecomte/friture.git")
build() {
cd friture
@@ -21,8 +21,10 @@ build() {
package() {
cd friture
python setup.py install --root="$pkgdir/"
- install -Dm775 resources/images/friture.iconset/icon_512x512.png $pkgdir/usr/share/pixmaps/friture.png
- install -Dm775 $srcdir/friture.desktop $pkgdir/usr/share/applications/friture.desktop
+ install -Dm644 resources/images/friture.iconset/icon_512x512.png $pkgdir/usr/share/pixmaps/${pkgname%%-git}.png
+ install -Dm644 appimage/${pkgname%%-git}.desktop "$pkgdir"/usr/share/applications/${pkgname%%-git}.desktop
+ sed -i "s|usr|/usr|g" "$pkgdir"/usr/share/applications/${pkgname%%-git}.desktop
+
}
pkgver() {
@@ -30,5 +32,4 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-md5sums=('SKIP'
-'90243c7bedd2dfca1429498561ce796b')
+md5sums=('SKIP')
diff --git a/friture.desktop b/friture.desktop
deleted file mode 100644
index a0b1139fc0ef..000000000000
--- a/friture.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Name=Friture
-Comment=Visualize and analyze live audio data in real-time
-GenericName=Friture
-Exec=friture %U
-Icon=friture
-Type=Application
-StartupNotify=true
-Categories=Utility;
-Categories=Audio;Multimedia;