summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302016-05-19 16:14:45 +0200
committerM0Rf302016-05-19 16:14:45 +0200
commite6a8d5326ff4ea1ddbce1d89a4edb17aaf1c7f0f (patch)
tree5eb486ff2d3af4aa93f34f4a54ad26a0822a1d0b
downloadaur-e6a8d5326ff4ea1ddbce1d89a4edb17aaf1c7f0f.tar.gz
first commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD34
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e27872620592
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Thu May 19 14:14:30 UTC 2016
+pkgbase = friture-git
+ pkgdesc = An application to visualize and analyze live audio data in real-time.
+ pkgver = 1293.16c6714
+ pkgrel = 1
+ url = http://tlecomte.github.com/friture/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cython2
+ depends = pyqwt
+ depends = python-scipy
+ depends = python-psutil
+ depends = python-pyaudio
+ depends = python-opengl
+ depends = python-pyqt5
+ optdepends = jack: for JACK I/O support
+ source = friture::git+https://github.com/tlecomte/friture.git
+ md5sums = SKIP
+
+pkgname = friture-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62674582992e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: M0Rf30
+
+pkgname=friture-git
+pkgver=1293.16c6714
+pkgrel=1
+pkgdesc="An application to visualize and analyze live audio data in real-time."
+arch=(i686 x86_64)
+url="http://tlecomte.github.com/friture/"
+license=('GPL3')
+depends=('pyqwt' 'python-scipy' 'python-psutil' 'python-pyaudio' 'python-opengl' 'python-pyqt5')
+optdepends=('jack: for JACK I/O support')
+makedepends=('cython2')
+source=("friture::git+https://github.com/tlecomte/friture.git")
+md5sums=('866407aefd359ae16015f4ce6a2cd212')
+
+build() {
+ cd friture
+ python2 setup.py build
+}
+
+package() {
+ cd friture
+ python setup.py install --root="$pkgdir/"
+
+ # python2, CRLF fix
+# sed -i 's/\r//;s/env python/&2/' `find "$pkgdir" -name "*.py"` \
+# "$pkgdir/usr/bin/$pkgname"
+}
+
+pkgver() {
+ cd friture
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+md5sums=('SKIP')