summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Laß2024-02-16 20:25:55 +0100
committerMichael Laß2024-02-16 20:31:12 +0100
commit460d08a41d04c978fc162dceaef4b9f435e841cb (patch)
treeebc8ad157ce20668817bcffcfaabb725e86a5eee
parent5b9d2ba9d9d9332ab3e255773b1ee99314026d0c (diff)
downloadaur-fritzing.tar.gz
Build and install translations
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b4900a1a353..c0447571d18f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fritzing
pkgdesc = PCB layout prototyping application
pkgver = 1.0.2
- pkgrel = 1
+ pkgrel = 2
url = http://fritzing.org
install = fritzing.install
arch = aarch64
@@ -10,6 +10,7 @@ pkgbase = fritzing
license = GPL3
makedepends = boost
makedepends = git
+ makedepends = qt6-tools
depends = libgit2
depends = polyclipping
depends = qt6-serialport
diff --git a/PKGBUILD b/PKGBUILD
index c820e46796f1..9a897e86b3b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ pkgname=fritzing
# while there is also "d" for development versions. This would not be correctly
# parsed by `pkgver` anyway (d > b), so let's leave out the b suffix entirely.
pkgver=1.0.2
-pkgrel=1
+pkgrel=2
# Tag version can be obtained from github release page. Sometimes this is the
# version number itself, sometimes some CD-magicnumber thing. There can be
@@ -35,7 +35,7 @@ arch=('aarch64' 'i686' 'x86_64')
url=http://fritzing.org
license=(GPL3)
install=fritzing.install
-makedepends=('boost' 'git')
+makedepends=('boost' 'git' 'qt6-tools')
depends=('libgit2' 'polyclipping' 'qt6-serialport' 'qt6-svg' 'quazip-qt6' 'ngspice')
source=("git+https://github.com/fritzing/fritzing-app.git#commit=${_gitrev}"
"git+https://github.com/fritzing/fritzing-parts.git#commit=${_partsrev}"
@@ -77,6 +77,9 @@ prepare() {
build() {
cd "${srcdir}"/fritzing-app
+ # build translations
+ /usr/lib/qt6/lrelease-pro phoenix.pro
+
mkdir build && cd build
qmake6 ..
make