summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lass2015-06-08 20:50:53 +0200
committerMichael Lass2015-06-08 20:51:27 +0200
commitd92838964f2e4e9dacb0656c1fa962a975a8fc95 (patch)
tree67760133dc257591f6be46b0b5e61dbec32949df
downloadaur-d92838964f2e4e9dacb0656c1fa962a975a8fc95.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..785af2da8915
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = fritzing
+ pkgdesc = PCB layout prototyping application
+ pkgver = 0.9.2b
+ pkgrel = 1
+ url = http://fritzing.org
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = boost
+ depends = java-environment
+ depends = libsm
+ depends = libxkbcommon-x11
+ depends = python2
+ depends = qt5-serialport
+ depends = qt5-svg
+ source = https://github.com/fritzing/fritzing-app/archive/0.9.2b.tar.gz
+ source = https://github.com/fritzing/fritzing-parts/archive/de7f8a4c8f7df4ed57386edf68275cdd66a1910d.tar.gz
+ sha256sums = 6e9dbb94a4ca5e23effc2056f471c78913b9efa4c154ced94de8f72bfe29735f
+ sha256sums = b9eeac2d8b169eb80162f607b5bedd9a2c92191690685955d674c14ba7aefcc1
+
+pkgname = fritzing
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ddc2053d8d72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Michael Lass <bevan@bi-co.net>
+# Contributor: Tolga HOŞGÖR <fasdfasdas@gmail.com>
+# Contributor: Henning Mueller <henning@orgizm.net>
+
+# This PKGBUILD is maintained on github:
+# https://github.com/michaellass/AUR
+
+pkgname=fritzing
+pkgver=0.9.2b
+pkgrel=1
+partsrev=de7f8a4c8f7df4ed57386edf68275cdd66a1910d
+pkgdesc='PCB layout prototyping application'
+arch=('i686' 'x86_64')
+url=http://fritzing.org
+license=(GPL3)
+makedepends=('boost')
+# libsm and libxkbcommon-x11 are optdepends for qt5-base that are needed for the xcb plugin used by Fritzing
+depends=('java-environment' 'libsm' 'libxkbcommon-x11' 'python2' 'qt5-serialport' 'qt5-svg')
+source=(https://github.com/fritzing/fritzing-app/archive/${pkgver}.tar.gz
+ https://github.com/fritzing/fritzing-parts/archive/${partsrev}.tar.gz)
+sha256sums=('6e9dbb94a4ca5e23effc2056f471c78913b9efa4c154ced94de8f72bfe29735f'
+ 'b9eeac2d8b169eb80162f607b5bedd9a2c92191690685955d674c14ba7aefcc1')
+
+prepare() {
+ mv "$srcdir"/fritzing-parts-${partsrev}/* "$srcdir"/fritzing-app-${pkgver}/parts
+}
+
+build() {
+ cd "$srcdir"/fritzing-app-${pkgver}
+ qmake-qt5
+ make
+}
+
+package() {
+ cd "$srcdir"/fritzing-app-${pkgver}
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ # patch python scripts to use python2
+ find "$pkgdir"/usr/share/$pkgname/parts/part-gen-scripts/ \
+ -name \*.py -exec sed -i \
+ -e 's#/usr/bin/env python$#/usr/bin/env python2#' \
+ -e 's#/usr/bin/python$#/usr/bin/python2#' {} \;
+}