summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-26 16:04:11 +0800
committerzxp198210052024-02-26 16:04:11 +0800
commitd0825a8a79773a23e1abc8d3786d636ff9e35a25 (patch)
treeed3227c8a47c26ac8b13c887ffbedbb8a177ebea
parent4d68232bde71d9464b4948cad200a886c754c0cb (diff)
downloadaur-d0825a8a79773a23e1abc8d3786d636ff9e35a25.tar.gz
fix errors
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
-rw-r--r--frontimer.sh9
3 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d9c7039fc37..5d5ef7dcfe8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = frontimer
pkgdesc = Desktop timer application always displayed in the forefront of the screen
pkgver = 0.1.17
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/seita1996/frontimer
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 5407d483c172..2c5955a2a21a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=frontimer
pkgver=0.1.17
_electronversion=25
_nodeversion=20
-pkgrel=3
+pkgrel=4
pkgdesc="Desktop timer application always displayed in the forefront of the screen"
arch=('any')
url="https://github.com/seita1996/frontimer"
@@ -34,15 +34,18 @@ _ensure_local_nvm() {
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname}.sh"
_ensure_local_nvm
- gendesk -f -n -q --categories "Utility" --name "${pkgname}" --exec "${pkgname} %U"
+ gendesk -f -n -q --categories="Utility" --name="${pkgname}" --exec="${pkgname} %U"
cd "${srcdir}/${pkgname}.git"
export npm_config_build_from_source=true
export ELECTRON_SKIP_BINARY_DOWNLOAD=1
export SYSTEM_ELECTRON_VERSION="$(electron${_electronversion} -v | sed 's/v//g')"
+ export npm_config_target="${SYSTEM_ELECTRON_VERSION}"
export ELECTRONVERSION="${_electronversion}"
+ export npm_config_disturl=https://electronjs.org/headers
+ HOME="${srcdir}/.electron-gyp"
yarn install --cache-folder "${srcdir}/.yarn_cache"
yarn run build
yarn run ebuilder:linux
diff --git a/frontimer.sh b/frontimer.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/frontimer.sh
+++ b/frontimer.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file