summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-01 18:46:41 +0800
committerzxp198210052024-03-01 18:46:41 +0800
commit4925cb9916297df2df29ad618009f49fbfad008f (patch)
treea09d81d45746b1a0aa8026ba42a7596a570dc7e1
parent5345c85d3cb9057d04fd0c0c8bb951cb653b4ef6 (diff)
downloadaur-4925cb9916297df2df29ad618009f49fbfad008f.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--frosch.sh9
3 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75ce7d8881ea..9ebe61729ff9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = frosch-bin
pkgdesc = Frosch, software para juego de rana electrónica o rana digital.
pkgver = 2.0.2
- pkgrel = 8
+ pkgrel = 9
url = https://github.com/ivanrey/Frosch
arch = i686
arch = x86_64
license = MIT
makedepends = gendesk
- depends = electron11
+ depends = electron11-bin
provides = frosch=2.0.2
conflicts = frosch
source = LICENSE-2.0.2::https://raw.githubusercontent.com/ivanrey/Frosch/v2.0.2/LICENSE
source = frosch.sh
sha256sums = 70d564391aa89ca77317a0716d27d450d939c41d0554a66da392b28784d6fa7d
- sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
+ sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
source_i686 = frosch-2.0.2-i686.zip::https://github.com/ivanrey/Frosch/releases/download/v2.0.2/Frosch-linux-ia32.zip
sha256sums_i686 = 78ca0dbd64a0e6e1155632219d3990a76358abd8c385ef88a7094edc1a8aa8b6
source_x86_64 = frosch-2.0.2-x86_64.zip::https://github.com/ivanrey/Frosch/releases/download/v2.0.2/Frosch-linux-x64.zip
diff --git a/PKGBUILD b/PKGBUILD
index 6d62ba8e6deb..bef35d83b3c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=frosch-bin
_appname=Frosch
pkgver=2.0.2
_electronversion=11
-pkgrel=8
+pkgrel=9
pkgdesc="Frosch, software para juego de rana electrónica o rana digital."
arch=(
'i686'
@@ -14,7 +14,7 @@ license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- "electron${_electronversion}"
+ "electron${_electronversion}-bin"
)
makedepends=(
'gendesk'
@@ -26,15 +26,15 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('70d564391aa89ca77317a0716d27d450d939c41d0554a66da392b28784d6fa7d'
- '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
+ '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
sha256sums_i686=('78ca0dbd64a0e6e1155632219d3990a76358abd8c385ef88a7094edc1a8aa8b6')
sha256sums_x86_64=('16841565eecd5b9946711cfafdf9a0959c60fada1870c624f5d65f31cc31252f')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app|g" \
+ -e "s|@runname@|app|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- gendesk -q -f -n --categories "Game" --name "${_appname}" --exec "${pkgname%-bin} %U"
+ gendesk -q -f -n --categories="Game" --name="${_appname}" --exec="${pkgname%-bin} %U"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/frosch.sh b/frosch.sh
index 0d20cddc70ca..86cb3dc6a9bf 100644
--- a/frosch.sh
+++ b/frosch.sh
@@ -1,14 +1,15 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file