summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-29 15:18:32 +0800
committerzxp198210052024-01-29 15:18:32 +0800
commit5345c85d3cb9057d04fd0c0c8bb951cb653b4ef6 (patch)
tree88600f3a708f49c3b6479ba3f82fe00181cfe611
parent9f7e8028b8a91b4b734fd4642740a2f7b6aa48ef (diff)
downloadaur-5345c85d3cb9057d04fd0c0c8bb951cb653b4ef6.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--frosch.sh9
3 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7dbfcaedfe79..75ce7d8881ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = frosch-bin
pkgdesc = Frosch, software para juego de rana electrónica o rana digital.
pkgver = 2.0.2
- pkgrel = 7
+ pkgrel = 8
url = https://github.com/ivanrey/Frosch
arch = i686
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = frosch-bin
source = LICENSE-2.0.2::https://raw.githubusercontent.com/ivanrey/Frosch/v2.0.2/LICENSE
source = frosch.sh
sha256sums = 70d564391aa89ca77317a0716d27d450d939c41d0554a66da392b28784d6fa7d
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
source_i686 = frosch-2.0.2-i686.zip::https://github.com/ivanrey/Frosch/releases/download/v2.0.2/Frosch-linux-ia32.zip
sha256sums_i686 = 78ca0dbd64a0e6e1155632219d3990a76358abd8c385ef88a7094edc1a8aa8b6
source_x86_64 = frosch-2.0.2-x86_64.zip::https://github.com/ivanrey/Frosch/releases/download/v2.0.2/Frosch-linux-x64.zip
diff --git a/PKGBUILD b/PKGBUILD
index 3b6633fbfc30..6d62ba8e6deb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=frosch-bin
_appname=Frosch
pkgver=2.0.2
_electronversion=11
-pkgrel=7
+pkgrel=8
pkgdesc="Frosch, software para juego de rana electrónica o rana digital."
arch=(
'i686'
@@ -26,7 +26,7 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('70d564391aa89ca77317a0716d27d450d939c41d0554a66da392b28784d6fa7d'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
sha256sums_i686=('78ca0dbd64a0e6e1155632219d3990a76358abd8c385ef88a7094edc1a8aa8b6')
sha256sums_x86_64=('16841565eecd5b9946711cfafdf9a0959c60fada1870c624f5d65f31cc31252f')
build() {
@@ -34,7 +34,7 @@ build() {
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@appasar@|app|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- gendesk -q -f -n --categories "Game" --name "${_appname}" --exec "${pkgname%-bin}"
+ gendesk -q -f -n --categories "Game" --name "${_appname}" --exec "${pkgname%-bin} %U"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/frosch.sh b/frosch.sh
index c77c53567639..0d20cddc70ca 100644
--- a/frosch.sh
+++ b/frosch.sh
@@ -6,12 +6,9 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" "$@"
- exit
+ exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
else
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
- exit
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file