summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvy Foster2018-01-25 20:24:10 -0600
committerIvy Foster2018-01-25 20:24:10 -0600
commit9ec33ea7d8562a374b38bab4cbb13bcc61bdae9b (patch)
tree8a53d138320ddb2c599ed8669a16ac030110285c
parent4425cdc56a1a1e96a3323714a60d003b79df012a (diff)
downloadaur-9ec33ea7d8562a374b38bab4cbb13bcc61bdae9b.tar.gz
Update prepare() for current build, fix spurious conflict with self
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50ae89b0bbd5..6fb477a024a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = frotz-git
pkgdesc = Z-machine interpreter for interactive fiction games
- pkgver = 2.44.r188.g869c99e
+ pkgver = 2.44.r196.gf3ceac9
pkgrel = 1
url = http://frotz.sourceforge.net/
arch = i686
arch = x86_64
license = GPL
- provides = frotz
- conflicts = frotz
source = git+https://github.com/DavidGriffith/frotz
md5sums = SKIP
pkgname = frotz-ncurses-git
depends = ncurses
+ provides = frotz
+ conflicts = frotz
pkgname = frotz-dumb-git
+ provides = frotz-dumb
+ conflicts = frotz-dumb
diff --git a/PKGBUILD b/PKGBUILD
index 96e9b7eb3a31..cb5c35c91da7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,10 @@
pkgbase=frotz-git
pkgname=(frotz-ncurses-git frotz-dumb-git)
-pkgver=2.44.r188.g869c99e
+pkgver=2.44.r196.gf3ceac9
pkgrel=1
pkgdesc='Z-machine interpreter for interactive fiction games'
-conflicts=(frotz)
-provides=(frotz)
-
arch=(i686 x86_64)
url='http://frotz.sourceforge.net/'
license=(GPL)
@@ -23,11 +20,8 @@ pkgver() {
prepare() {
cd frotz
sed '/^PREFIX/ s:/usr/local:/usr:
- /^CONFIG_DIR = $(PREFIX)/ s/^/#/
- /^CONFIG_DIR/ s:/usr/local::
- /^CURSES/ s/-lcurses/-lncurses/
- /^#CURSES_DEF/ s/^#//' \
- -i Makefile
+ /^MAN_PREFIX/ s:$:/share:
+ ' -i Makefile
}
build() {
@@ -37,6 +31,8 @@ build() {
}
package_frotz-ncurses-git() {
+ conflicts=(frotz)
+ provides=(frotz)
depends=('ncurses')
cd frotz
@@ -44,6 +40,9 @@ package_frotz-ncurses-git() {
}
package_frotz-dumb-git() {
+ conflicts=(frotz-dumb)
+ provides=(frotz-dumb)
+
cd frotz
make DESTDIR="$pkgdir" install_dumb
}