summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-07-09 16:40:45 +0200
committersmls2015-07-09 16:40:45 +0200
commitf2d88befd5b8c89ae62f83a445a0a02971bbc3dd (patch)
tree2a65fd961fc73fb13af77b52577f2d61ee8472ee
downloadaur-f2d88befd5b8c89ae62f83a445a0a02971bbc3dd.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD55
-rw-r--r--frozensynapse.desktop11
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..958c0643d15a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = frozensynapse
+ pkgdesc = A top-down simultaneous-turn-based tactical combat game (Humble Bundle version)
+ pkgver = 1.0.32+h20120614
+ pkgrel = 1
+ url = http://www.frozensynapse.com/
+ arch = i686
+ arch = x86_64
+ license = custom: "commercial"
+ depends = lib32-mesa
+ depends = lib32-libgl
+ depends = lib32-sdl
+ depends = lib32-openal
+ optdepends = lib32-ati-dri: Support for the ATI (open-source) graphics driver
+ optdepends = lib32-intel-dri: Support for the Intel graphics driver
+ optdepends = lib32-nouveau-dri: Support for the Nouveau graphics driver
+ options = !upx
+ source = hib://frozensynapse-linux-32-1339710386.run
+ source = frozensynapse.desktop
+ md5sums = bcbfce04bd280b69bddea7a4bef0864a
+ md5sums = e5480e851062946708572273c9545b9c
+
+pkgname = frozensynapse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93aaa7ae86c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Sam S. <smls75@gmail.com>
+# Contributor: Gadget3000 <gadget3000 at msn dot com>
+# Contributor: wido <widowild [ta] myopera [tod] com>
+
+pkgname=frozensynapse
+pkgver=1.0.32+h20120614
+_hibver=1339710386
+pkgrel=1
+pkgdesc="A top-down simultaneous-turn-based tactical combat game (Humble Bundle version)"
+url="http://www.frozensynapse.com/"
+license=('custom: "commercial"')
+arch=('i686' 'x86_64')
+if [[ $CARCH == i686 ]]; then
+ depends=('mesa' 'libgl' 'sdl' 'openal')
+else
+ depends=('lib32-mesa' 'lib32-libgl' 'lib32-sdl' 'lib32-openal')
+ optdepends=("lib32-ati-dri: Support for the ATI (open-source) graphics driver"
+ "lib32-intel-dri: Support for the Intel graphics driver"
+ "lib32-nouveau-dri: Support for the Nouveau graphics driver")
+fi
+options=('!upx')
+PKGEXT='.pkg.tar'
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+_archive="$pkgname-linux-32-$_hibver.run"
+source=("hib://$_archive"
+ "$pkgname.desktop")
+md5sums=('bcbfce04bd280b69bddea7a4bef0864a'
+ 'e5480e851062946708572273c9545b9c')
+
+package(){
+ cd "$srcdir"
+
+ # Extract game files
+ chmod +x $_archive
+ ./$_archive --mode unattended --unattendedmodeui none --prefix "$pkgdir/opt/$pkgname"
+
+
+ cd "$pkgdir"
+
+ # Remove unneeded files
+ rm opt/$pkgname/{uninstall,*.desktop}
+
+ # Fix permissions
+ chmod 644 opt/$pkgname/cacert.pem
+
+ # Install launch script
+ echo -e "#!/bin/sh\ncd /opt/$pkgname && exec ./FrozenSynapse \$*" \
+ > "$srcdir/launcher.sh"
+ install -Dm755 "$srcdir/launcher.sh" usr/bin/$pkgname
+
+ # Install desktop entry & icon
+ install -Dm644 "$srcdir/$pkgname.desktop" usr/share/applications/$pkgname.desktop
+ install -Dm644 opt/$pkgname/fs_icon.png usr/share/pixmaps/$pkgname.png
+}
diff --git a/frozensynapse.desktop b/frozensynapse.desktop
new file mode 100644
index 000000000000..64197e5ff7ed
--- /dev/null
+++ b/frozensynapse.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Categories=Game;
+Name=Frozen Synapse
+Comment=Mode 7 Games
+GenericName=Turn-Based Tactics Game
+Icon=frozensynapse
+Exec=/usr/bin/frozensynapse
+Terminal=false
+StartupNotify=false