summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorШалыгин Константин Николаевич2020-11-30 11:43:57 +0300
committerШалыгин Константин Николаевич2020-11-30 11:43:57 +0300
commit3a53ee992ed763edccb23b08d0acc2709ff6441e (patch)
tree5a031d5911f47ebde294a01a97a434a1798a21c9
parent4e2675b0f64021f42f82e4d92b577346156ec2f0 (diff)
downloadaur-3a53ee992ed763edccb23b08d0acc2709ff6441e.tar.gz
Added patch that fixes YANG access-list validation
-rw-r--r--.SRCINFO4
-rw-r--r--7621.patch73
-rw-r--r--PKGBUILD9
3 files changed, 82 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a138fbe9d36..395b5315d9c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = frr
pkgdesc = FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, BFD, VRRP, NHRP and EIGRP.
pkgver = 7.5
- pkgrel = 1
+ pkgrel = 2
url = https://frrouting.org/
arch = x86_64
arch = aarch64
@@ -39,11 +39,13 @@ pkgbase = frr
source = frr.tmpfiles
source = frr_7.4_Archlinux.patch
source = frr-init-functions
+ source = https://github.com/FRRouting/frr/pull/7621.patch
sha256sums = 54066e82a82751ec5876d9b67aa0cb24fe94e19e7371af290ac25099eda9f136
sha256sums = 9371cc0522d13621c623b5da77719052bdebdceb7ffdbdc06fc32a2f07118e7e
sha256sums = 6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89
sha256sums = 4662bcd384d40be42cc55182310cada2461c18f126f432dd31c9db286641bef8
sha256sums = e6e2592a8b0b18f7f173186fb4ebf23e642b3d912179f0bb36251962ca64cd7a
+ sha256sums = 035bb015dbbbe0013629845030230be99da2169dfe3fd8075cf2d7cfac48145c
pkgname = frr
diff --git a/7621.patch b/7621.patch
new file mode 100644
index 000000000000..54003974006d
--- /dev/null
+++ b/7621.patch
@@ -0,0 +1,73 @@
+From de4132bfe509edfe72afcd2b13f6f32e0f553157 Mon Sep 17 00:00:00 2001
+From: Igor Ryzhov <iryzhov@nfware.com>
+Date: Fri, 27 Nov 2020 21:53:25 +0300
+Subject: [PATCH] yang: fix cisco access list source value
+
+Source value must be a choice between host, network and any, not a set
+of all three.
+
+Fixes #7599.
+
+Signed-off-by: Igor Ryzhov <iryzhov@nfware.com>
+---
+ yang/frr-filter.yang | 44 ++++++++++++++++++++++++--------------------
+ 1 file changed, 24 insertions(+), 20 deletions(-)
+
+diff --git a/yang/frr-filter.yang b/yang/frr-filter.yang
+index 400a0931789..eb84dd74608 100644
+--- a/yang/frr-filter.yang
++++ b/yang/frr-filter.yang
+@@ -154,29 +154,33 @@ module frr-filter {
+ }
+ }
+ case cisco {
+- leaf host {
+- description "Host to match";
+- type inet:ipv4-address;
+- }
+- container network {
+- leaf address {
+- mandatory true;
+- description "Network address part.";
++ choice standard-value {
++ description "Source value to match";
++
++ leaf host {
++ description "Host to match";
+ type inet:ipv4-address;
+ }
+- leaf mask {
+- mandatory true;
+- description "Network mask/wildcard part.";
+- type inet:ipv4-address;
++ container network {
++ leaf address {
++ mandatory true;
++ description "Network address part.";
++ type inet:ipv4-address;
++ }
++ leaf mask {
++ mandatory true;
++ description "Network mask/wildcard part.";
++ type inet:ipv4-address;
++ }
++ }
++ leaf source-any {
++ /*
++ * Was `any`, however it conflicts with `any` leaf
++ * outside this choice.
++ */
++ description "Match any";
++ type empty;
+ }
+- }
+- leaf source-any {
+- /*
+- * Was `any`, however it conflicts with `any` leaf
+- * outside this choice.
+- */
+- description "Match any";
+- type empty;
+ }
+
+ choice extended-value {
diff --git a/PKGBUILD b/PKGBUILD
index 97b34e400858..def4a0cbd046 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='frr'
pkgver='7.5'
-pkgrel='1'
+pkgrel='2'
pkgdesc='FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, BFD, VRRP, NHRP and EIGRP.'
arch=('x86_64' 'aarch64')
url="https://frrouting.org/"
@@ -23,16 +23,19 @@ source=("https://github.com/FRRouting/${pkgname}/archive/${pkgname}-${pkgver}.ta
"${pkgname}.sysusers"
"${pkgname}.tmpfiles"
"${pkgname}_7.4_Archlinux.patch"
- "frr-init-functions")
+ "frr-init-functions"
+ "https://github.com/FRRouting/frr/pull/7621.patch")
sha256sums=('54066e82a82751ec5876d9b67aa0cb24fe94e19e7371af290ac25099eda9f136'
'9371cc0522d13621c623b5da77719052bdebdceb7ffdbdc06fc32a2f07118e7e'
'6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89'
'4662bcd384d40be42cc55182310cada2461c18f126f432dd31c9db286641bef8'
- 'e6e2592a8b0b18f7f173186fb4ebf23e642b3d912179f0bb36251962ca64cd7a')
+ 'e6e2592a8b0b18f7f173186fb4ebf23e642b3d912179f0bb36251962ca64cd7a'
+ '035bb015dbbbe0013629845030230be99da2169dfe3fd8075cf2d7cfac48145c')
prepare() {
cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
patch -p1 -i "${srcdir}/${pkgname}_7.4_Archlinux.patch"
+ patch -p1 -i "${srcdir}/7621.patch"
autoreconf -fvi
./configure \