summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2020-01-21 16:08:58 +0700
committerKonstantin Shalygin2020-01-21 16:08:58 +0700
commit4e2cd6596de9f4cb5516bd72098c6777a5a556a5 (patch)
treefdfc9dccd4a85a34eb43c0f7bc3e9dc49e759c54
parent42c9174dbc967f37cbb145031820f8bbed950d29 (diff)
downloadaur-4e2cd6596de9f4cb5516bd72098c6777a5a556a5.tar.gz
Drop systemd units per binary, use frr.service only
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--frr_7.2_Archlinux.patch303
3 files changed, 6 insertions, 312 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05d1de91995f..40c00920463c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = frr
pkgdesc = FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, BFD, VRRP, NHRP and EIGRP.
pkgver = 7.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://frrouting.org/
- arch = any
+ arch = x86_64
license = GPL2
checkdepends = python-pytest
makedepends = patch
@@ -41,7 +41,7 @@ pkgbase = frr
sha256sums = 40fea6ff007453e27761a0372cde51fd8279f89984dff009092eebe2a7b29be3
sha256sums = 9371cc0522d13621c623b5da77719052bdebdceb7ffdbdc06fc32a2f07118e7e
sha256sums = 6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89
- sha256sums = fbbd0b6d40dffbdb850ecabf91ab6bd22da07aa2c7c6406af5e3816988905e02
+ sha256sums = 36ac07e04b54bb2c4228bf4b380c133c134962ff5f39bc84c03972bc93b1261d
sha256sums = e6e2592a8b0b18f7f173186fb4ebf23e642b3d912179f0bb36251962ca64cd7a
pkgname = frr
diff --git a/PKGBUILD b/PKGBUILD
index e790e5c555a4..6ab0c2a49c52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
pkgname='frr'
pkgver='7.2.1'
-pkgrel='1'
+pkgrel='2'
pkgdesc='FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, BFD, VRRP, NHRP and EIGRP.'
-arch=('any')
+arch=('x86_64')
url="https://frrouting.org/"
license=('GPL2')
depends=('libcap' 'libnl' 'readline' 'ncurses' 'perl' 'pam' 'json-c' 'net-snmp'
@@ -27,7 +27,7 @@ source=("https://github.com/FRRouting/${pkgname}/archive/${pkgname}-${pkgver}.ta
sha256sums=('40fea6ff007453e27761a0372cde51fd8279f89984dff009092eebe2a7b29be3'
'9371cc0522d13621c623b5da77719052bdebdceb7ffdbdc06fc32a2f07118e7e'
'6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89'
- 'fbbd0b6d40dffbdb850ecabf91ab6bd22da07aa2c7c6406af5e3816988905e02'
+ '36ac07e04b54bb2c4228bf4b380c133c134962ff5f39bc84c03972bc93b1261d'
'e6e2592a8b0b18f7f173186fb4ebf23e642b3d912179f0bb36251962ca64cd7a')
prepare() {
@@ -74,9 +74,6 @@ package() {
pushd "redhat"
sed -ri 's|/var/run/frr|/run/frr|g' "${pkgname}.logrotate"
install -Dm0644 "${pkgname}.logrotate" "${pkgdir}/etc/logrotate.d/${pkgname}"
- for d in babeld bgpd bfdd eigrpd isisd ldpd nhrpd ospf6d ospfd ospfd-instance@ pbrd pimd ripd ripngd staticd zebra; do
- install -Dm0644 ${d}.service "${pkgdir}/usr/lib/systemd/system/${d}.service"
- done
install -Dm0644 "${pkgname}.pam" "${pkgdir}/etc/pam.d/${pkgname}"
install -Dm0644 "${srcdir}/${pkgname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
install -Dm0644 "${srcdir}/${pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
diff --git a/frr_7.2_Archlinux.patch b/frr_7.2_Archlinux.patch
index 829236da20fc..98bf70b76657 100644
--- a/frr_7.2_Archlinux.patch
+++ b/frr_7.2_Archlinux.patch
@@ -12,309 +12,6 @@ diff -Naupr frr-frr-7.2_orig/ospf6d/ospf6_abr.c frr-frr-7.2/ospf6d/ospf6_abr.c
/* Delete new route */
ospf6_route_delete(route);
-diff -Naupr frr-frr-7.2_orig/redhat/babeld.service frr-frr-7.2/redhat/babeld.service
---- frr-frr-7.2_orig/redhat/babeld.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-7.2/redhat/babeld.service 2019-10-31 14:06:59.201098655 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=Babel routing daemon
-+Documentation=man:babeld(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/babeld.pid
-+ExecStart=/usr/bin/babeld -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-7.2_orig/redhat/bfdd.service frr-frr-7.2/redhat/bfdd.service
---- frr-frr-7.2_orig/redhat/bfdd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-7.2/redhat/bfdd.service 2019-10-31 14:06:59.201098655 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=Communication failure detection daemon
-+Documentation=man:bfdd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/bfdd.pid
-+ExecStart=/usr/bin/bfdd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-7.2_orig/redhat/bgpd.service frr-frr-7.2/redhat/bgpd.service
---- frr-frr-7.2_orig/redhat/bgpd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-7.2/redhat/bgpd.service 2019-10-31 14:06:59.201098655 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=BGP routing daemon
-+Documentation=man:bgpd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/bgpd.pid
-+ExecStart=/usr/bin/bgpd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-7.2_orig/redhat/eigrpd.service frr-frr-7.2/redhat/eigrpd.service
---- frr-frr-7.2_orig/redhat/eigrpd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-7.2/redhat/eigrpd.service 2019-10-31 14:06:59.201098655 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=EIGRP routing daemon
-+Documentation=man:eigrpd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/eigrpd.pid
-+ExecStart=/usr/bin/eigrpd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-7.2_orig/redhat/isisd.service frr-frr-7.2/redhat/isisd.service
---- frr-frr-7.2_orig/redhat/isisd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-7.2/redhat/isisd.service 2019-10-31 14:06:59.201098655 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=IS-IS routing daemon
-+Documentation=man:isis(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/isisd.pid
-+ExecStart=/usr/bin/isisd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-7.2_orig/redhat/ldpd.service frr-frr-7.2/redhat/ldpd.service
---- frr-frr-7.2_orig/redhat/ldpd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-7.2/redhat/ldpd.service 2019-10-31 14:06:59.201098655 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=LDP engine
-+Documentation=man:ldpd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/ldpd.pid
-+ExecStart=/usr/bin/ldpd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-7.2_orig/redhat/nhrpd.service frr-frr-7.2/redhat/nhrpd.service
---- frr-frr-7.2_orig/redhat/nhrpd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-7.2/redhat/nhrpd.service 2019-10-31 14:06:59.201098655 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=NHRP daemon
-+Documentation=man:nhrpd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/nhrpd.pid
-+ExecStart=/usr/bin/nhrpd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-7.2_orig/redhat/ospf6d.service frr-frr-7.2/redhat/ospf6d.service
---- frr-frr-7.2_orig/redhat/ospf6d.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-7.2/redhat/ospf6d.service 2019-10-31 14:06:59.201098655 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=OSPF routing daemon for IPv6
-+Documentation=man:ospfd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/ospf6d.pid
-+ExecStart=/usr/bin/ospf6d -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-7.2_orig/redhat/ospfd-instance@.service frr-frr-7.2/redhat/ospfd-instance@.service
---- frr-frr-7.2_orig/redhat/ospfd-instance@.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-7.2/redhat/ospfd-instance@.service 2019-10-31 14:06:59.201098655 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=OSPF routing daemon instance %i
-+Documentation=man:ospfd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service ospfd.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/ospfd-%i.pid
-+ExecStart=/usr/bin/ospfd -n %i -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-7.2_orig/redhat/ospfd.service frr-frr-7.2/redhat/ospfd.service
---- frr-frr-7.2_orig/redhat/ospfd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-7.2/redhat/ospfd.service 2019-10-31 14:06:59.201098655 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=OSPF routing daemon
-+Documentation=man:ospfd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/ospfd.pid
-+ExecStart=/usr/bin/ospfd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-7.2_orig/redhat/pbrd.service frr-frr-7.2/redhat/pbrd.service
---- frr-frr-7.2_orig/redhat/pbrd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-7.2/redhat/pbrd.service 2019-10-31 14:06:59.201098655 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=PBR routing daemon
-+Documentation=man:pbrd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/pbrd.pid
-+ExecStart=/usr/bin/pbrd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-7.2_orig/redhat/pimd.service frr-frr-7.2/redhat/pimd.service
---- frr-frr-7.2_orig/redhat/pimd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-7.2/redhat/pimd.service 2019-10-31 14:06:59.201098655 +0700
-@@ -0,0 +1,14 @@
-+[Unit]
-+Description=PIM multicast routing engine
-+Documentation=man:pimd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/pimd.pid
-+ExecStart=/usr/bin/pimd -d
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-7.2_orig/redhat/ripd.service frr-frr-7.2/redhat/ripd.service
---- frr-frr-7.2_orig/redhat/ripd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-7.2/redhat/ripd.service 2019-10-31 14:06:59.201098655 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=RIP routing daemon
-+Documentation=man:ripd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/ripd.pid
-+ExecStart=/usr/bin/ripd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-7.2_orig/redhat/ripngd.service frr-frr-7.2/redhat/ripngd.service
---- frr-frr-7.2_orig/redhat/ripngd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-7.2/redhat/ripngd.service 2019-10-31 14:06:59.201098655 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=RIP routing daemon for IPv6
-+Documentation=man:ripngd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/ripngd.pid
-+ExecStart=/usr/bin/ripngd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-7.2_orig/redhat/staticd.service frr-frr-7.2/redhat/staticd.service
---- frr-frr-7.2_orig/redhat/staticd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-7.2/redhat/staticd.service 2019-10-31 14:06:59.201098655 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=Zebra daemon responsible for management of static routes
-+Documentation=man:staticd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/staticd.pid
-+ExecStart=/usr/bin/staticd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-7.2_orig/redhat/zebra.service frr-frr-7.2/redhat/zebra.service
---- frr-frr-7.2_orig/redhat/zebra.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-7.2/redhat/zebra.service 2019-10-31 14:06:59.201098655 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=GNU Zebra routing manager
-+Documentation=man:zebra(8)
-+After=network.target
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/zebra.pid
-+ExecStartPre=/usr/bin/ip route flush proto zebra
-+ExecStart=/usr/bin/zebra -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
diff -Naupr frr-frr-7.2_orig/tools/etc/frr/daemons frr-frr-7.2/tools/etc/frr/daemons
--- frr-frr-7.2_orig/tools/etc/frr/daemons 2019-10-15 21:44:47.000000000 +0700
+++ frr-frr-7.2/tools/etc/frr/daemons 2019-10-31 14:25:39.747396103 +0700