summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2019-05-10 15:28:36 +0700
committerKonstantin Shalygin2019-05-10 15:28:36 +0700
commit802e13d8b9c3e701497aa3098fcec0f17f26ffea (patch)
treee625376b82c213fe2b52c53d47cedb492e5f5e21
parent3a52551553800c1d8042f5bcdf31e6fe14420ed4 (diff)
downloadaur-802e13d8b9c3e701497aa3098fcec0f17f26ffea.tar.gz
New patch and improvments for: https://github.com/FRRouting/frr/issues/4261
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD29
-rw-r--r--frr_7.0_Archlinux.patch111
3 files changed, 86 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9593587dd18..c89e230d350a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
# Generated by mksrcinfo v8
-# Mon May 6 04:21:53 UTC 2019
+# Fri May 10 08:27:50 UTC 2019
pkgbase = frr
pkgdesc = FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, NHRP and EIGRP.
pkgver = 7.0
- pkgrel = 3
+ pkgrel = 4
url = https://frrouting.org/
arch = any
license = GPL2
checkdepends = python-pytest
- makedepends = gcc
makedepends = net-snmp
makedepends = bison
makedepends = c-ares
@@ -25,11 +24,15 @@ pkgbase = frr
depends = rtrlib
depends = libyang
depends = libunwind
+ optdepends = rsyslog: syslog support
provides = quagga
provides = quagga_cumulus
conflicts = quagga
conflicts = babeld
conflicts = quagga_cumulus
+ backup = etc/frr/frr.conf
+ backup = etc/frr/daemons.conf
+ backup = etc/frr/vtysh.conf
source = https://github.com/FRRouting/frr/archive/frr-7.0.tar.gz
source = frr.sysusers
source = frr.tmpfiles
@@ -39,7 +42,7 @@ pkgbase = frr
sha256sums = 9371cc0522d13621c623b5da77719052bdebdceb7ffdbdc06fc32a2f07118e7e
sha256sums = 6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89
sha256sums = 9d98a0b5d7016cb66fe3cbec234f70327f0a961de47f7eae39a5bd4477b072ce
- sha256sums = 4bfa5c8014869741cae034c6dfb133acfe5c4dbe37838770e36a6796dc411b39
+ sha256sums = 93b2cb90ca438841db38d582708e12d4bed77f498e1a494057a804b31bdc323a
pkgname = frr
diff --git a/PKGBUILD b/PKGBUILD
index 5cdbe24a438c..0a11fef9905d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,21 @@
pkgname='frr'
pkgver='7.0'
-pkgrel='3'
+pkgrel='4'
pkgdesc='FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, NHRP and EIGRP.'
arch=('any')
url="https://frrouting.org/"
license=('GPL2')
-depends=('libcap' 'libnl' 'readline' 'ncurses' 'perl' 'pam' 'json-c' 'net-snmp' 'rtrlib'
- 'libyang' 'libunwind')
-makedepends=('gcc' 'net-snmp' 'bison' 'c-ares' 'perl-xml-libxml' 'python-sphinx')
+depends=('libcap' 'libnl' 'readline' 'ncurses' 'perl' 'pam' 'json-c' 'net-snmp'
+ 'rtrlib' 'libyang' 'libunwind')
+makedepends=('net-snmp' 'bison' 'c-ares' 'perl-xml-libxml' 'python-sphinx')
checkdepends=('python-pytest')
+optdepends=('rsyslog: syslog support')
conflicts=('quagga' 'babeld' 'quagga_cumulus')
provides=('quagga' 'quagga_cumulus')
+backup=("etc/${pkgname}/${pkgname}.conf"
+ "etc/${pkgname}/daemons.conf"
+ "etc/${pkgname}/vtysh.conf")
source=("https://github.com/FRRouting/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz"
"${pkgname}.sysusers"
"${pkgname}.tmpfiles"
@@ -23,7 +27,7 @@ sha256sums=('15b62dc0c52531e4bcefa6b830e9b9b07d1d0f189c2110307dbc19d80b719354'
'9371cc0522d13621c623b5da77719052bdebdceb7ffdbdc06fc32a2f07118e7e'
'6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89'
'9d98a0b5d7016cb66fe3cbec234f70327f0a961de47f7eae39a5bd4477b072ce'
- '4bfa5c8014869741cae034c6dfb133acfe5c4dbe37838770e36a6796dc411b39')
+ '93b2cb90ca438841db38d582708e12d4bed77f498e1a494057a804b31bdc323a')
prepare() {
cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
@@ -40,7 +44,7 @@ prepare() {
--sbindir="/usr/bin" \
--sysconfdir="/etc/${pkgname}" \
--localstatedir="/run/${pkgname}" \
- --enable-exampledir="/etc/${pkgname}" \
+ --enable-exampledir="/usr/share/doc/${pkgname}/examples" \
--with-libpam \
--enable-snmp="agentx" \
--enable-multipath=256 \
@@ -69,17 +73,26 @@ package() {
cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
- cd "redhat"
+ pushd "redhat"
sed -ri 's|/var/run/frr|/run/frr|g' "${pkgname}.logrotate"
sed -ri 's|/usr/lib/frr/|/usr/bin/|g' "${pkgname}.service"
install -Dm0644 "${pkgname}.logrotate" "${pkgdir}/etc/logrotate.d/${pkgname}"
for d in babeld bgpd bfdd eigrpd isisd ldpd nhrpd ospf6d ospfd ospfd-instance@ pbrd pimd ripd ripngd staticd zebra; do
install -Dm0644 ${d}.service "${pkgdir}/usr/lib/systemd/system/${d}.service"
done
- install -Dm0644 "daemons" "${pkgdir}/etc/frr/daemons.conf"
install -Dm0644 "${pkgname}.pam" "${pkgdir}/etc/pam.d/${pkgname}"
install -Dm0644 "${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
install -Dm0644 "${srcdir}/${pkgname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
install -Dm0644 "${srcdir}/${pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
+ popd
+
+ pushd "tools/etc"
+ install -Dm0644 "${pkgname}/daemons" "${pkgdir}/etc/${pkgname}/daemons.conf"
+ install -Dm0644 "iproute2/rt_protos.d/${pkgname}.conf" "${pkgdir}/etc/iproute2/rt_protos.d/${pkgname}.conf"
+ install -Dm0644 "${pkgname}/${pkgname}.conf" "${pkgdir}/etc/${pkgname}/${pkgname}.conf"
+ install -Dm0644 "${pkgname}/vtysh.conf" "${pkgdir}/etc/${pkgname}/vtysh.conf"
+ install -Dm0644 "rsyslog.d/45-${pkgname}.conf" "${pkgdir}/etc/rsyslog.d/45-${pkgname}.conf"
+ popd
+
chown -R 177:177 "${pkgdir}/etc/frr"
}
diff --git a/frr_7.0_Archlinux.patch b/frr_7.0_Archlinux.patch
index a48af7998bf2..fa96bc7bbd31 100644
--- a/frr_7.0_Archlinux.patch
+++ b/frr_7.0_Archlinux.patch
@@ -1,59 +1,64 @@
-diff -Naupr frr-frr-7.0_orig/redhat/daemons frr-frr-7.0/redhat/daemons
---- frr-frr-7.0_orig/redhat/daemons 2019-03-01 06:32:04.000000000 +0700
-+++ frr-frr-7.0/redhat/daemons 2019-04-29 13:42:01.157161004 +0700
-@@ -35,7 +35,7 @@
- # group "frrvty" and set to ug=rw,o= though. Check /etc/pam.d/frr, too.
- #
- watchfrr_enable=yes
--watchfrr_options="-r '/usr/lib/frr/frr restart %s' -s '/usr/lib/frr/frr start %s' -k '/usr/lib/frr/frr stop %s'"
-+watchfrr_options="-d -r '/usr/bin/frr restart %s' -s '/usr/bin/frr start %s' -k '/usr/bin/frr stop %s'"
- #
- zebra=no
- bgpd=no
-@@ -58,23 +58,23 @@ fabricd=no
+diff -Naupr frr-frr-7.0_orig/tools/etc/frr/daemons frr-frr-7.0/tools/etc/frr/daemons
+--- frr-frr-7.0_orig/tools/etc/frr/daemons 2019-03-01 06:32:04.000000000 +0700
++++ frr-frr-7.0/tools/etc/frr/daemons 2019-05-10 14:52:18.395888041 +0700
+@@ -29,6 +29,8 @@ sharpd=no
+ pbrd=no
+ bfdd=no
+ fabricd=no
++zebra=yes
++#ospfd_instances="1,2,3"
+
#
- # Command line options for the daemons
+ # If this option is set the /etc/init.d/frr script automatically loads
+@@ -36,26 +38,27 @@ fabricd=no
+ # Check /etc/pam.d/frr if you intend to use "vtysh"!
#
--zebra_options=("-A 127.0.0.1")
--bgpd_options=("-A 127.0.0.1")
--ospfd_options=("-A 127.0.0.1")
--ospf6d_options=("-A ::1")
--ripd_options=("-A 127.0.0.1")
--ripngd_options=("-A ::1")
--isisd_options=("-A 127.0.0.1")
--ldpd_options=("-A 127.0.0.1")
--pimd_options=("-A 127.0.0.1")
--nhrpd_options=("-A 127.0.0.1")
--eigrpd_options=("-A 127.0.0.1")
--babeld_options=("-A 127.0.0.1")
--sharpd_options=("-A 127.0.0.1")
--pbrd_options=("-A 127.0.0.1")
--staticd_options=("-A 127.0.0.1")
--bfdd_options=("-A 127.0.0.1")
--fabricd_options=("-A 127.0.0.1")
-+zebra_options=("-A 127.0.0.1 -d")
-+bgpd_options=("-A 127.0.0.1 -d")
-+ospfd_options=("-A 127.0.0.1 -d")
-+ospf6d_options=("-A ::1 -d")
-+ripd_options=("-A 127.0.0.1 -d")
-+ripngd_options=("-A ::1 -d")
-+isisd_options=("-A 127.0.0.1 -d")
-+ldpd_options=("-A 127.0.0.1 -d")
-+pimd_options=("-A 127.0.0.1 -d")
-+nhrpd_options=("-A 127.0.0.1 -d")
-+eigrpd_options=("-A 127.0.0.1 -d")
-+babeld_options=("-A 127.0.0.1 -d")
-+sharpd_options=("-A 127.0.0.1 -d")
-+pbrd_options=("-A 127.0.0.1 -d")
-+staticd_options=("-A 127.0.0.1 -d")
-+bfdd_options=("-A 127.0.0.1 -d")
-+fabricd_options=("-A 127.0.0.1 -d")
+ vtysh_enable=yes
+-zebra_options=" -A 127.0.0.1 -s 90000000"
+-bgpd_options=" -A 127.0.0.1"
+-ospfd_options=" -A 127.0.0.1"
+-ospf6d_options=" -A ::1"
+-ripd_options=" -A 127.0.0.1"
+-ripngd_options=" -A ::1"
+-isisd_options=" -A 127.0.0.1"
+-pimd_options=" -A 127.0.0.1"
+-ldpd_options=" -A 127.0.0.1"
+-nhrpd_options=" -A 127.0.0.1"
+-eigrpd_options=" -A 127.0.0.1"
+-babeld_options=" -A 127.0.0.1"
+-sharpd_options=" -A 127.0.0.1"
+-pbrd_options=" -A 127.0.0.1"
+-staticd_options="-A 127.0.0.1"
+-bfdd_options=" -A 127.0.0.1"
+-fabricd_options="-A 127.0.0.1"
++zebra_options=" -A 127.0.0.1 -s 90000000 -d"
++bgpd_options=" -A 127.0.0.1 -d"
++ospfd_options=" -A 127.0.0.1 -d"
++ospf6d_options=" -A ::1 -d"
++ripd_options=" -A 127.0.0.1 -d"
++ripngd_options=" -A ::1 -d"
++isisd_options=" -A 127.0.0.1 -d"
++pimd_options=" -A 127.0.0.1 -d"
++ldpd_options=" -A 127.0.0.1 -d"
++nhrpd_options=" -A 127.0.0.1 -d"
++eigrpd_options=" -A 127.0.0.1 -d"
++babeld_options=" -A 127.0.0.1 -d"
++sharpd_options=" -A 127.0.0.1 -d"
++pbrd_options=" -A 127.0.0.1 -d"
++staticd_options="-A 127.0.0.1 -d"
++bfdd_options=" -A 127.0.0.1 -d"
++fabricd_options="-A 127.0.0.1 -d"
- #
- # If the vtysh_enable is yes, then the unified config is read
+ # The list of daemons to watch is automatically generated by the init script.
+-#watchfrr_options=""
++watchfrr_enable=yes
++watchfrr_options="-d -r '/usr/bin/frr restart %s' -s '/usr/bin/frr start %s' -k '/usr/bin/frr stop %s'"
+
+ # for debugging purposes, you can specify a "wrap" command to start instead
+ # of starting the daemon directly, e.g. to use valgrind on ospfd:
diff -Naupr frr-frr-7.0_orig/tools/frrcommon.sh.in frr-frr-7.0/tools/frrcommon.sh.in
--- frr-frr-7.0_orig/tools/frrcommon.sh.in 2019-03-01 06:32:04.000000000 +0700
-+++ frr-frr-7.0/tools/frrcommon.sh.in 2019-04-29 11:50:28.826125721 +0700
++++ frr-frr-7.0/tools/frrcommon.sh.in 2019-05-10 14:32:51.919090139 +0700
@@ -270,7 +270,7 @@ load_old_config() {
[ -s "$oldcfg" ] || return 0
grep -v '^[[:blank:]]*\(#\|$\)' "$oldcfg" > /dev/null || return 0
@@ -76,7 +81,7 @@ diff -Naupr frr-frr-7.0_orig/tools/frrcommon.sh.in frr-frr-7.0/tools/frrcommon.s
. "$C_PATH/daemons"
diff -Naupr frr-frr-7.0_orig/tools/frr.in frr-frr-7.0/tools/frr.in
--- frr-frr-7.0_orig/tools/frr.in 2019-03-01 06:32:04.000000000 +0700
-+++ frr-frr-7.0/tools/frr.in 2019-04-29 11:50:23.632759891 +0700
++++ frr-frr-7.0/tools/frr.in 2019-05-10 14:32:51.919090139 +0700
@@ -500,10 +500,9 @@ check_status()
#########################################################
@@ -91,7 +96,7 @@ diff -Naupr frr-frr-7.0_orig/tools/frr.in frr-frr-7.0/tools/frr.in
# Read configuration variable file if it is present
diff -Naupr frr-frr-7.0_orig/tools/frr-reload frr-frr-7.0/tools/frr-reload
--- frr-frr-7.0_orig/tools/frr-reload 2019-03-01 06:32:04.000000000 +0700
-+++ frr-frr-7.0/tools/frr-reload 2019-04-29 11:51:12.669735089 +0700
++++ frr-frr-7.0/tools/frr-reload 2019-05-10 14:32:51.919090139 +0700
@@ -1,7 +1,7 @@
#!/bin/sh